Multi Domain SSL on Primary Network Domain and Mapped Domain

I am currently setting up my network. I purchased a Multi domain comdo SSL certificate that supports 3 domains. I generated it to protect my primary domain and 1 SAN which is the mapped domain I am trying to protect.

My sites are hosted on GoDaddy and I installed the certificate. I came back to my domain mapping settings in my network and enabled https for original domain. It works fine for the original domain and redirects to https without a problem.

I am now struggling with setting up https for the mapped domain. I have tried everything. I have tried adding a redirect from .htaccess folder. I have tried to manually go to the site on the mapped domain and force ssl from the domain mapping plugin. I have tried writing all sorts of various regex combinations in htaccess to try to make it work. It just wont happen.

I keep getting stuck with the same error.

The http://www.mappeddomain.com page isn’t working
http://www.mappeddomain.com redirected you too many times.

My network structure is sub-domains. So the actual url is mapped.primarydomain.com which I guess redirects to http://www.mappeddomain.com which I am now asking to redirect to https://www.mappeddomain.com and perhaps that is what the browsers dont like.

Can someone please tell me what am I doing wrong or how can I accomplish https on my mappeddomain as well. I have looked everywhere I could think of but cannot find a solution to this.

  • Adam Czajczyk

    Hello ZeeMaster!

    I checked your site and there's been some "glitches" in configuration of the sub-site: Site URL and Home URL were "mixed up" using both sub-domain and mapped domain names in different places. There's also an issue of SSL protection over sub-domain.

    I have cleared that up a little and the current stat is:

    - sub-site front-end still loads fine via mapped domain over http connection but https redirects it to http
    - dashboard of sub-site will load fine with a little "twist": when you try to access it and it goes over https and displays 404 not found error, just replace "https://" in URL with "http://".

    That's however not a solution but a "preparation" rather than that. What happens now is that the domain is mapped as "https" and also Domain Mapping seems to be properly redirecting from "http" to "https" but there's still another redirect back and that one we need to track down.

    You mentioned that you tried various ways to force the redirect. Can you please make sure that your current .htaccess doesn't include any redirects and is a standard .htaccess for sub-domain based Multisite? You'll find default .htaccess rules here (make sure that you check correct version):

    https://codex.wordpress.org/htaccess

    Can you also please check if there are any redirects set on server?

    Let me know please and then I'll decide on further steps to be taken depending on your replay :slight_smile:

    Best regards,
    Adam

  • ZeeMaster

    Hey Adam,

    Thank you for the response and taking a look at the website. Yes I did play around with the site url and home url a little in the hopes of figuring out the issue. But did not work. Thank you for changing it all back to correct settings through.

    I can see that now the back end pages are all http as you have turned https off from the setting. The front end on the primary site does load on https.

    For the subdomain sites, I have checked the .htaccess file as well as the hosting server. No redirects are happening anywhere other than through the plugin.

    Although on the sub domain site under domain mapping in settings, no matter what you select in the drop down, after clicking "Map Domain", it always display http for the url. But then if you go back to the primary domain to see all the mapped domains list, you can see that the mapped domain has https:// so I am thinking that is just a display issue in the plugin.

    I removed the mapped domain and then mapped it as http and then using the plugin options tried to force ssl on the home page but that is giving the same error as well. Did I just waste my money getting a multi domain SSL?

  • Predrag Dubajic

    Hi ZeeMaster,

    Are you now using default .htaccess rules for your type of installation, if you have some other rules there can you paste the content of your .htaccess rules so we can check it out?
    Please wrap the code inside code tag.

    Also, did you made any changes on your site because I can no longer access it and when I check it with a tool like site24x7.com I get "Read time out"?

    Best regards,
    Predrag

  • ZeeMaster

    Hey Predrag,

    Thank you for all the support that you guys have given me. But I was able to resolve the problem after a support post on a different post with a similar issue.

    The post by Nithin is over here that said

    the issue with https, changing to http was related to a known bug, as a workaround you'll have to map the domains first without www prefix, and then with www prefix. I have already done the mentioned steps in your subsite, under Tools > Domain Mapping, and now your websites are pointing to https without any issue.

    I thank you all for your support but it seems to be all working now. :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.