Multi domains plugin will not install

Hi, I have tried to download the plugin called multi domain, however, I get an error that no plugin exists within the zip doc that I download.
Other plugins that I have downloaded have worked fine.
Is there a known issue currently with this plugin?
Thank you