Multi site admin site has a white screen

I recently updated some plugins and received the white screen of death on all my sites on my host. I have one multi site and 3 individual sites. I updated Wordpress to 4.3 and deactivated all my plugins and got back all my sites except the multi site main site and the admin area. Do you have any ideas of what could be wrong if I can access all my multi site websites except the main site and admin area? All plugins are removed from the plugin folder.

I am on bluehost running Wordpress 4.3 multi site.

Thanks,
Mike

  • Wharrf

    Hi there,

    Could you go to your wordpress root folder and edit wp-config.php, add/edit
    `define('WP_DEBUG', true);

    this will turn on your errors and you can view your home screen and see what the errors are. Post the errors here and maybe we could help.

    There could be a lot of reasons.

    Hint: Don't use bluehost. Use a Managed WordPress Service like FlyWheel or WP Engine instead and they will actually help you out with such situations.

  • Tyler Postle

    Hey Michael,

    Hope you're doing well today!

    As @Wharrf kindly mentioned above, turning on wp_debug within your wp-config.php will help narrow down the issue as you will most likely see an error when trying to visit your main site. Once you copy down the error you see then you can turn debug off again.

    However, if you've already deactivated all your plugins and it's still not showing then there is a good chance it's a conflict with the theme you're using on the mainsite. In this case, you can re-name the theme folder inside /wp-content/themes/ this will automatically swap your site back to default 2015 if it's still installed. If you still can't access it then, it could be a server side issue in which case checking your wp_debug log and server error log would be helpful :slight_smile:

    Look forward to hearing back!

    All the best,
    Tyler

    Edit: oops looks like Sajid and I both posted at the same time :p

  • Michael

    All plugins and themes are removed. Here are the warnings. Looks like it might be wp super cache, but I don't have that loaded? Any other thoughts?

    Warning: include_once(/home1/heartmed/public_html/thepharmacyconnection/wp-content/plugins/wp-super-cache/wp-cache-phase1.php): failed to open stream: No such file or directory in /home1/heartmed/public_html/thepharmacyconnection/wp-content/advanced-cache.php on line 10

    Warning: include_once(): Failed opening '/home1/heartmed/public_html/thepharmacyconnection/wp-content/plugins/wp-super-cache/wp-cache-phase1.php' for inclusion (include_path='.:disappointed:usr/php/54/usr/lib64:disappointed:usr/php/54/usr/share/pear') in /home1/heartmed/public_html/thepharmacyconnection/wp-content/advanced-cache.php on line 10

    Notice: wpdb::escape is deprecated since version 3.6! Use wpdb::prepare() or esc_sql() instead. in /home1/heartmed/public_html/thepharmacyconnection/wp-includes/functions.php on line 3411

  • Tyler Postle

    Hey Michael,

    Hope you're doing well today, sorry for such a delay!

    WP Super Cache makes quite a few changes to your install that don't revert when it is deactivated. You will likely find a lot of code from it in your .htaccess and also a line in your wp-config.php that will have a comment on it stating that it's from Super Cache. You can remove both of these.

    You can try deleting the advanced-cache.php file as well. it's a good idea to make a backup of it just in-case.

    Let us know if that resolves your issue, if you need any further assistance with this just let me know :slight_smile:

    Cheers,
    Tyler

  • Michael

    @Tyler Postle - Thanks for all your help.

    I looked at the WP Super Cache uninstall instructions (https://wordpress.org/plugins/wp-super-cache/other_notes/). The only thing I could not change was the htaccess file because it did not look like there was anything from WP Super Cache in the file.

    I now have back all my subdirectory sites, but still cannot access the main multisite or the network admin. I am still getting the white screen. The subdirectory sites are now on the 2015 theme since it is the only one available by default. The only error in the error log is:

    Notice: wpdb::escape is deprecated since version 3.6! Use wpdb::prepare() or esc_sql() instead. in /home1/heartmed/public_html/thepharmacyconnection/wp-includes/functions.php on line 3411

    I double checked and I don't have a single plugin or theme installed. I am going to play around with this more but let me know if you have any further recommendations. I would rather not rebuild everything.

    Thanks,
    Mike

  • Tyler Postle

    Hey Mike,

    Did you manage to get this sorted out?

    By any chance do you have any plugins in your /wp-content/mu-plugins/ folder. Those ones are "always active" plugins. You can disable these by temporarily changing the /mu-plugins/ folder name or removing the files within it.

    Another place custom code often is placed that could cause conflicts is in your themes functions.php, although if you switched the main site to default 2015 and you've never customized it before then that should be fine.

    If it's still an issue, let me know and we can have a closer look :slight_smile:

    Cheers,
    Tyler

  • Michael

    @Tyler Postle Here are the errors I am see on the main site.

    Notice: wpdb::escape is deprecated since version 3.6! Use wpdb::prepare() or esc_sql() instead. in /home1/heartmed/public_html/thepharmacyconnection/wp-includes/functions.php on line 3411

    Fatal error: require(): Failed opening required '/home1/heartmed/public_html/thepharmacyconnection/wp-content/themes/Twenty Fifteen/inc/custom-header.php' (include_path='.:disappointed:usr/php/54/usr/lib64:disappointed:usr/php/54/usr/share/pear') in /home1/heartmed/public_html/thepharmacyconnection/wp-content/themes/twentyfifteen/functions.php on line 341

    I don't see any errors (just a white screen) on the network admin screen.

    Thanks,
    Mike

  • Wharrf

    that's the oddest thing because it looks like your functions.php file was edited.

    the error is here : /home1/heartmed/public_html/thepharmacyconnection/wp-content/themes/twentyfifteen/functions.php on line 341

    can you go there and change this line

    home1/heartmed/public_html/thepharmacyconnection/wp-content/themes/Twenty Fifteen/inc/custom-header.php

    to

    home1/heartmed/public_html/thepharmacyconnection/wp-content/themes/twentyfifteen/inc/custom-header.php

    note the gap between twenty and fifteen and the CAPS? not sure why it's there

  • Michael

    @Wharrf - Thanks!

    I think we are getting closer. Now I can access the all the sub-sites and the admin sections of the network (I can access users/plugins/themes, etc) and the main site (add a post, setting, etc.). The areas I still cannot access are the dashboards for the network admin and main site and I cannot access the main site itself (front facing).

    Any more ideas?

    @Tyler Postle - Any ideas? I could give you temp access to the site if needed.

    Thanks,
    Mike

  • Tyler Postle

    Hey Mike,

    That would actually be helpful if you could send in temp access :slight_smile: FTP and wp-admin would be preferred. Credentials instead of support access may be needed in this case as with the admin issues you're experiencing the support access might not work.

    You can send that privately through our contact form: https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    Send in:

    Subject: "Attn: Tyler Postle"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Look forward to hearing back!

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.