Multi site--Can't access dashboards or new sites

I have a membership site and I have only used the multi site feature in the past for testing.

Now I need to create a few new sites. After creation I am unable to access the dashboard or the new site.

When I try to access the new site I get this message:

Apache is functioning normally

When I try to access the dashboard I get this message:

404 Not Found
The server can not find the requested page:

members.sisterhoodofsupport.com/wp-admin/ (port 80)
Please forward this error screen to members.sisterhoodofsupport.com's WebMaster.

Apache Server at members.sisterhoodofsupport.com Port 80

I am using wordpress 3.5.2 with membership premium 3.4.4.1 and buddypress 1.7.2 plugins.

The only dashboards I can access are network admin and my main site admin. The only site I can access is the main site (sisterhoodofsupport.com).

I don't know exactly when this happened as I have not tried to access this feature in quite a while.

Any help will be greatly appreciated.

Thanks,

JoAnn

  • aristath
    • Recruit

    Hello there JoAnn, I hope you're well today!

    It sounds like you never completed the Multisite setup on your network, hence the malfunctions.
    Please visit /wp-admin/network/setup.php on your site and follow the onscreen instructions to complete it.
    You can also access that page by going to Network Admin => Settings => Network Setup.
    You will have to make some adjustments to the wp-config.php and .htaccess files in your installation.

    I hope that helps!

    Cheers,
    Ari.

  • JoAnn
    • The Incredible Code Injector

    Hi Ari,

    Thanks for the quick reply. I had set it up for multi site and I have created and accessed new sites before. But, just to be certain i checked and re edited both my .htaccess file and my config.php file again.

    Still no difference.

    This has me stumped.

    JoAnn

  • sdgenxr
    • Design Lord, Child of Thor

    Hey JoAnn,

    Making sure you have wildcard DNS records enabled and that your host allows you to use wildcard DNS. Below is a snippet from the WPMU manual
    https://premium.wpmudev.org/manuals/wpmu-manual-2/creating-a-network-to-enable-wordpress-multisite/

    a. Sub- domains

    If you want to use sub-domains you will need to contact your host and ask them to set up Wildcard DNS records for your site e.g. log into your support area of pSek and ask them to set up Wildcard DNS records for your site.

    Sub-domains have site URLs like site1.domain.tld and site2.domain.tld
    Not all companies allow you to use sub-domains and you need to check with your hosting company before choosing this option.

  • JoAnn
    • The Incredible Code Injector

    My sites are hosted at pSek and I do have it set up for sub domains.

    I went into my c-panel and set up a sub domain for a site I had created.

    When I try to access the site I get these error messages (if you offer any help on these please be specific as I do not know how to fix these):

    Warning: array_merge() [function.array-merge]: Argument #1 is not an array in /home/sisterh0/public_html/test/wp-content/plugins/buddypress/bp-core/bp-core-loader.php on line 80

    Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /home/sisterh0/public_html/test/wp-content/plugins/buddypress/bp-core/bp-core-loader.php on line 80

    Warning: array_values() [function.array-values]: The argument should be an array in /home/sisterh0/public_html/test/wp-content/plugins/buddypress/bp-core/bp-core-loader.php on line 80

    Warning: array_values() [function.array-values]: The argument should be an array in /home/sisterh0/public_html/test/wp-content/plugins/buddypress/bp-core/bp-core-loader.php on line 80

    Warning: array_diff() [function.array-diff]: Argument #1 is not an array in /home/sisterh0/public_html/test/wp-content/plugins/buddypress/bp-core/bp-core-loader.php on line 80

    Warning: array_fill_keys() expects parameter 1 to be array, null given in /home/sisterh0/public_html/test/wp-content/plugins/buddypress/bp-core/bp-core-loader.php on line 80

    Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/sisterh0/public_html/test/wp-content/plugins/buddypress/bp-core/bp-core-loader.php:80) in /home/sisterh0/public_html/test/wp-content/plugins/classifieds/core/core.php on line 1012

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/sisterh0/public_html/test/wp-content/plugins/buddypress/bp-core/bp-core-loader.php:80) in /home/sisterh0/public_html/test/wp-content/plugins/classifieds/core/core.php on line 1012

  • aristath
    • Recruit

    The messages mentioned above are simply warnings, nothing to worry about.
    If you disable WP_DEBUG in your wp-config.php they should go away without any negative impact to your site.

    Could you please provide some more info about your server?
    Is it on shared hosting or a VPS/Dedicated server?
    Is it by any chance running nginx instead of apache?
    If it's a VPS/Dedicated server and you have ssh access, have you set-up the apache configuration file to AllowOverride All instead of AllowOverride None in the apache configuration files?

    Please advise,
    Ari.

  • JoAnn
    • The Incredible Code Injector

    The debug has always been set like this:

    define('WP_DEBUG', false);

    I am on a shared server. It is running apache.

    I am perplexed because when I set up sites before on this domain and there was no problem. I set them up and immediately was able to access the site and the dashboard.

    Thanks for taking the time to look into this, I really appreciate it.

    JoAnn

  • aristath
    • Recruit

    Most probably your host just has set this to true from their PHP configuration and doesn't allow you to change it.
    Error reporting should be by default turnet OFF in production servers, so would it be possible for you to contact them and ask that they disable error reporting in PHP?

    Cheers,
    Ari.

  • Dev4
    • Champion of Loops

    I looked and based on the 'your apache is funtioning normally' message you get when going to a random subdomain. I would say that our wildcard subdomains are not working.

    Youmay have set it up correctly and it can still not work,

    Here is what i do to fix this when the host points to word press as the problem

    1) check that i have set up wildcard subdomains in the cpanel
    2) place an index.html at the root that says "this is the root" inside (or under mainenance, or any simple message)
    This will disable wp at the root
    3) go to random.yourdomain.com if you do not see your html your wildcard subdomains are not working. Contact the host and show them
    When it is fixed delete your index.html

  • JoAnn
    • The Incredible Code Injector

    It is simply a new blog site set up through the Network Admin dashboard. I am able to do it on my other domains and I have done it in the past on this site, but it has ceased to work.

    The site is a paid membership site with Membership Premium and BuddyPress installed. As I said, I have not tried to set up a new blog site in a long time so I have no idea when the error started.

    Any ideas are welcome. Right now I'll try anything.

    JoAnn

  • Dev4
    • Champion of Loops

    Are your blogs subdirectory or subdomain?
    In other words

    Newblog.yourdomain.com
    Or
    Yourdoman.com/newblog
    ?

    I saw that you are trying to log in at a subdomain, whichnis why i ask.

    Can you give a link to a valid functioning blog/site ither than the main one?

  • JoAnn
    • The Incredible Code Injector

    None of the sites I created through the dashboard are accessible.

    I created a subdomain through my c-panel and that works fine.

    If I have to create them through my c-panel I will but I would like to know why I cannot access a site that I create through my wordpress dashboard.

    Here's a new error message I get in Chrome when I try to access the dashboard of a site I created in my wordpress dashboard: (I have cleared my cache and cookies)

    This webpage has a redirect loop
    The webpage at http://sisterhoodofsupport.com/newbies/wp-admin/ has resulted in too many redirects. Clearing your cookies for this site or allowing third-party cookies may fix the problem. If not, it is possibly a server configuration issue and not a problem with your computer.
    Here are some suggestions:
    Reload this webpage later.
    Learn more about this problem.
    Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects.

  • JoAnn
    • The Incredible Code Injector

    Yes, I have another site that works just fine and where I have created other sites. (the site that is not working is http://sisterhoodofsupport.com)

    Main site:

    http://sisterhoodofsupport.org/

    multi site created:

    http://sisterhoodofsupport.org/test/

    Here is a copy of my .htaccess file from the site that is not working:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]

    php_value memory_limit 512M

    #mozzila
    AddType audio/ogg oga ogg
    AddType video/ogg ogv
    AddType video/webm .webm
    #IE9
    AddType video/m4v m4v
    AddType video/mp4 mp4

  • Dev4
    • Champion of Loops

    .htaccess looks normal,
    I was asking if you had a subsite that was working on the domain you are having trouble with. Just trying to clarify if this site works for any subsites.

    No matter though, i think i see the issue.
    In your original post you mention this error

    404 Not Found
    The server can not find the requested page:
    members.sisterhoodofsupport.com/wp-admin/ (port 80)

    So it is looking for a subdomain site.
    But your other eb site is set up as a subdirectory site, so i am guessing that you have this site PARTLY set up as a sub domain site,

    To confirm this please check and see if subdomains is set to true or false in your wpconfig file.

  • JoAnn
    • The Incredible Code Injector

    I prefer the Yourdomain.com/newblog

    My subdomain, which I created through the c-panel is the typical Newblog.yourdomain.com.

    Really, either way would work for me as long as I can create it through the mulit site feature of wordpress in my dashboard.

    Thanks so much,

    JoAnn

  • Dev4
    • Champion of Loops

    It sounds like your wp is configured to be a subdirectory, but to be sure check in your wp-config file

    If the flag for subdirectory is true , change it to false, that way any sites will be created as a subdirectory

    Please check that and then if you changed it to false, try to create a new site.
    If it is already false let us know and we can aee what else it could be

  • JoAnn
    • The Incredible Code Injector

    Thanks again.

    Here is what my wp-config file says after the unique keys and salts

    /**
    * WordPress Database Table prefix.
    *
    * You can have multiple installations in one database if you give each a unique
    * prefix. Only numbers, letters, and underscores please!
    */
    $table_prefix = 'wp_';

    /**
    * WordPress Localized Language, defaults to English.
    *
    * Change this to localize WordPress. A corresponding MO file for the chosen
    * language must be installed to wp-content/languages. For example, install
    * de.mo to wp-content/languages and set WPLANG to 'de' to enable German
    * language support.
    */
    define ('WPLANG', '');

    /**
    * For developers: WordPress debugging mode.
    *
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    */
    define('WP_DEBUG', false);

    define('WP_ALLOW_MULTISITE', true);
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'sisterhoodofsupport.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    define ( 'BP_ENABLE_MULTIBLOG', true );
    define ( 'BP_MEMBERS_SLUG', 'our-members' );

    /* That's all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

  • JoAnn
    • The Incredible Code Injector

    Thanks again so much.

    I changed my wp-config file and created a new site.

    I am able to see it, here is the link: (it has no formatting)

    http://sisterhoodofsupport.com/falsetest/

    But when I try to sign in to the dashboard I get this error message:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@sisterhoodofsupport.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    Apache Server at sisterhoodofsupport.com Port 80

  • Dev4
    • Champion of Loops

    I am getting this error at that address
    Fatal error: Class 'BP_Group_Extension' not found in /home/sisterh0/public_html/wp-content/plugins/bp-group-calendar/groupcalendar/bp-group-calendar.php on line 103

    Disable your bp group calendar plug in,
    Also make sure you have an active template assigned for that site

    Then let's see what the results are

  • JoAnn
    • The Incredible Code Injector

    I have disabled the bp calendar.

    There is no place where I can assign an active template for that site or any site that I create. Is there something missing from my dashboard?

    I have deleted all the multi sites I have tried to create and am starting from scratch.

    Here is a new site I just tried to create.

    http://sisterhoodofsupport.com/anothertest/

    Here is the e-mail I received after creating the site. Please note the user name 'lexie' I have no idea where that is coming from and there is no password as there is no place to create that when I created the site.

    Dear User,

    Your new sisterhoodofsupport.com site has been successfully set up at:
    http://sisterhoodofsupport.com/anothertest/

    You can log in to the administrator account with the following information:
    Username: lexie
    Password: [User Set]
    Login Here: http://sisterhoodofsupport.com/anothertest/wp-login.php

    We hope you enjoy your new site.
    Thanks!

    --JoAnn @ Sisterhood of Support

  • Dev4
    • Champion of Loops

    I have no idea where the lexi came from,
    But , here is the good news. You did create a site.

    It looks like the site has no template, so i am guessing you deleted the default template.

    Each site has a dashboard, you should be able to go to the sites dashboard and under appearances, find Themes. Assign an active theme,

    Let me know how that goes

  • JoAnn
    • The Incredible Code Injector

    No, that has been the problem from the beginning. I cannot access the dashboard. Here is the error message I get: (I have cleared the cookies and history.)

    This webpage has a redirect loop
    The webpage at http://sisterhoodofsupport.com/anothertest/wp-admin/ has resulted in too many redirects. Clearing your cookies for this site or allowing third-party cookies may fix the problem. If not, it is possibly a server configuration issue and not a problem with your computer.
    Here are some suggestions:
    Reload this webpage later.
    Learn more about this problem.
    Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects.

  • Dev4
    • Champion of Loops

    I dont see anything tht would cause this in the htaccess.
    I think it is a conflict with one of the plug ins

    I would start disabling plug ins until it works.
    Or turn them all off, and see if it works.
    Then if it does, activate them one at a time until you see the problem again

  • JoAnn
    • The Incredible Code Injector

    I have disabled all plugins except membership premium and buddypress. Without those I have no site.

    Testing still reveals the same. I can create a site but cannot access the dashboard--here is the message I get when I try:

    This webpage has a redirect loop
    The webpage at http://sisterhoodofsupport.com/test5/wp-admin/ has resulted in too many redirects. Clearing your cookies for this site or allowing third-party cookies may fix the problem. If not, it is possibly a server configuration issue and not a problem with your computer.
    Here are some suggestions:
    Reload this webpage later.
    Learn more about this problem.
    Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects.

    And if I visit the site there is no theme attached to it.

    This is so frustrating.

  • Dev4
    • Champion of Loops

    I would still disable the remaining plug ins, just to determine if one of them is causing the problem.

    If we can identify what is causing the problem then it could be possible to fix it.

    It may not be the problem but disabling plugins is a good way to start debugging.

  • Dev4
    • Champion of Loops

    I may have found the issue.
    Part of your .htaccess redirects are repeated
    Try this, find the section shown below
    Put the # sign where i show them here, on the duplicate redirects
    NOTE in your current htaccess file the # signs are not n these lines.
    I am suggesting you add them and try again
    This is only for the 4 lnes above the php_value memory_limit 512M line

    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    # RewriteCond %{REQUEST_FILENAME} -f [OR]
    # RewriteCond %{REQUEST_FILENAME} -d
    # RewriteRule ^ - [L]
    # RewriteRule . index.php [L]

    php_value memory_limit 512M

  • JoAnn
    • The Incredible Code Injector

    Hi again,

    And thanks so much for pursuing this problem.

    I changed the .htaccess file as you suggested and created a new site and still have exactly the same results. The site is not attached to any theme and when I try to get to the dashboard I get the redirect error message.

    Sorry. :slight_frown:

  • Dev4
    • Champion of Loops

    Ok at this point i would suggest that you disable the remaining plug ins and see if this works at all.

    I know you need these plug ins, but if one of them is causing this you need to know before you can do anything about it,

    In addition, @aristath earlier asked who your host is, and what type of accunt/server set up you have. Can you provide any details on that?

  • JoAnn
    • The Incredible Code Injector

    I disabled all of the plugins by changing the name of the plugin file. I created a new site and still could not access the dashboard.

    The permissions are 755

    sisterhoodofsupport.org is not the problem site.

    sisterhoodofsupport.com is the problem site

    I can log into my dashboard for the main site (but not in Chrome--but I am assuming that is another issue, right now I am using internet explorer).

    I cannot log into any dashboard of any site I create as a multi site on sisterhoodofsupport.com

    My hosting company is pSek and the site in on a shared server.

    Thanks again, I am tearing my hair out.

    JoAnn

  • JoAnn
    • The Incredible Code Injector

    Nope. Here's what I get:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@sisterhoodofsupport.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    --------------------------------------------------------------------------------

    Apache Server at sisterhoodofsupport.com Port 80

  • Dev4
    • Champion of Loops

    try replacing your htaccess with this

    RewriteOptions inherit
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    • Renee
      • New Recruit

      Hi Dev,

      I'm having a similar issue of not being able to see my subdomains. It appears that Apache is not setup to point all wildcard domains to the same directory. I have a support ticket in place with my host about this. But, I'd like to know what were the changes you made to the above .htaccess file to get JoAnn access to her sites. My multisite is definitely setup in domain mode. Thanks!

        • Renee
          • New Recruit

          No worries Jack. I didn't take the age of this thread into consideration when I asked my question, oops. I already have a thread open regarding my issue and have a few wonderful people troubleshooting. I came to this thread from a link one of them provided, think it would shed some light on my issue, which it may have. Just wanted to see what @Dev changed in the .htaccess file that might be helpful to me. Thanks!

          • Jack Kitterhing
            • Code Norris

            Hi Renee,

            No problem at all :slight_smile:

            Looks like the .htaccess here is for sub directories, from your thread it looks like you are on sub domains, in which case your .htaccess there is correct :slight_smile:

            I see my colleagues Ash and Patrick are assisting, there be along ASAP :slight_smile:

            Thank you!

            Kind Regards
            Jack.

          • Dev4
            • Champion of Loops

            Hi @Renee
            I hope they have you all sorted out on the other thread,
            Fyi, the changes were just what i posted.
            I just had her use that exactly, replacing whatever was there before with this,,,

            Your problem may be different.
            I am guessing the host needs to fix your wildcard subdomains
            (Just because that is a common issue)

            RewriteOptions inherit
            RewriteEngine On
            RewriteBase /
            RewriteRule ^index\.php$ - [L]

            # add a trailing slash to /wp-admin
            RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

            RewriteCond %{REQUEST_FILENAME} -f [OR]
            RewriteCond %{REQUEST_FILENAME} -d
            RewriteRule ^ - [L]
            RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
            RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
            RewriteRule . index.php [L]

  • JoAnn
    • The Incredible Code Injector

    OMG! It worked.

    I created a test2 site and I was able to get into the dashboard from my main dashboard and attach a theme to it.

    OUTSTANDING!

    Thank you so, so much.

    Now, if I can just get that Chrome issue solved I will be really happy. I will write another post on that.

    Again, thank you so much for all of your hard work.

    JoAnn

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.