Multi-Site Content Copier (Not Copying Featured Images)

I have tried this plugin on two different Wordpress Setups/MultiSite Networks and have had the same successes (love the plugin) but also the same issue. It doesn't copy over the featured image from the source article to the destination posts. I tried this over a course of about 7 months, testing various things to no avail. If you would like to try it out on our network, we are testing this on a staging network right now, so no worries about messing things up .... I will gladly give you access.

Test Example;

Source Article;
http://stag.goleegenerals.com/2017/03/30/brady-leads-biggest-comeback-patriots-win-34-28-in-ot/

Destination Sites;
http://stag.lolakers.com/2017/03/30/brady-leads-biggest-comeback-patriots-win-34-28-in-ot/
http://stag.losaltosathletics.org/brady-leads-biggest-comeback-patriots-win-34-28-in-ot/
http://stag.beltontigerathletics.com/2017/03/30/brady-leads-biggest-comeback-patriots-win-34-28-in-ot/

Thanks for your help in looking at this, I look forward to hearing from you!

  • Denitsa

    Hello Matthew,
    I hope you're having a beautiful day!

    I was able to successfully copy over a post along with its featured image on my sandbox MU instal, so this must be something on your end. Did you use Content Copier from Content Copier panel or did you try to copy directly from post?

    Just a quick one to be sure, you have the Copy images (required for featured images) box checked, right?

    As a start, could you please make a basic theme/plugin conflict test? To perform it, please follow all the steps described on a flowchart in this article (you may need to scroll the page down a little):
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    If the above doesn't lead to any result, could you please access your server through FTP, edit the wp-config.php file, find a line like
    define('WP_DEBUG', false);

    and replace it with the following (if the above line doesn’t exist, simply insert next snippet just above the /* That's all, stop editing! Happy blogging. */ comment)

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    The log will be saved to a debug.log file inside the "/wp-content" folder. Please save the file as a .txt and attach it to your next post.
    If the file's larger than 5MB you might need to upload it somewhere like Dropbox and share the link here.

    Indeed you're right to suggest testing this out on your network, I could tell you better about the issue if I could see it live. Would you mind allowing Support Access so we can have a closer look at this?
    This could be done via Dashboard - WPMU DEV -> Support -> Support Access -> Grant Access or by following this guide here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Looking forward to hearing back from you once you grant that!

    Cheers,
    Denitsa

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.