Multi-site directory created in wordpress yet not viewable in front end

When I create a new site in multi-site in wordpress 3.01. I click on the site after I create it and I recieve the site not found error. Is this a common error that is resolved my adjusting a setting?

  • bt1161
    • Design Lord, Child of Thor

    Thank you for your reply. Do I need to have the website service set-up a wildcard if I choose the directory option?
    I understood that I didn't have to have the wildcard set-up if I used the directory option. I didn't choose the sub-domain option.
    Thank you

  • JoseffB
    • The Crimson Coder

    Oh your using directories. No wild card is needed for directories. Di you select the directory option when installing, as default is sub-domain. If you upgraded from 2.9 you would never get this option and need to do some hacking in your config.

    Do you have an example of your config file, htaccess file , site url that we can see?

  • bt1161
    • Design Lord, Child of Thor

    Config file:
    <?php
    /**
    * The base configurations of the WordPress.
    *
    * This file has the following configurations: MySQL settings, Table Prefix,
    * Secret Keys, WordPress Language, and ABSPATH. You can find more information
    * by visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
    * wp-config.php} Codex page. You can get the MySQL settings from your web host.
    *
    * This file is used by the wp-config.php creation script during the
    * installation. You don't have to use the web site, you can just copy this file
    * to "wp-config.php" and fill in the values.
    *
    * @package WordPress
    */

    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'XXXXX');

    /** MySQL database username */
    define('DB_USER', 'XXXXX');

    /** MySQL database password */
    define('DB_PASSWORD', 'XXXXXX');

    /** MySQL hostname */
    define('DB_HOST', 'forhisministryus.fatcowmysql.com');

    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');

    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');

    /**#@+
    * Authentication Unique Keys and Salts.
    *
    * Change these to different unique phrases!
    * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
    * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
    *
    * @since 2.6.0
    */
    define('AUTH_KEY', 'c]#(|WXg-s#8h~TQ+Q|Y[r|E.ePg|(og3ZaSKk=}tuWLv:;^qKz7-+h^KuEZ%dfi');
    define('SECURE_AUTH_KEY', 'Q)mWbIo|)h-p|?Mb*]VsC_A<?=egEJ>=dUZv1_>FjV02cr;.B>&2w<>Z=I-E B!d');
    define('LOGGED_IN_KEY', 'jl5eO!Bg7|;{o.)[pkl-bjVFy7*aJH_fLI7YU0|IDPQwlvFkm)=K@[i?FP9_%Vam');
    define('NONCE_KEY', '1+ ox??hF|6y=`4ur#%Q<o^;$wfr&8GYDZN!2BQ+X]B.QJ~zf!A?X}CDZ}P>$6?:');
    define('AUTH_SALT', 'V3r^FokOhMlNGMys3:6#1pb-ToG]W1AOlI#w}z?~+I|.iCWZ!Skh(WSgt%b5tJ');
    define('SECURE_AUTH_SALT', 'Sfug<-{aRikuwua74w3|a$gk!u+(P!J-]rnG@91-/-w{9+jtbL:;H`%z@w|zl3');
    define('LOGGED_IN_SALT', '1wRkd3]r%Bj2RkX[Tocld!b_@kjUt!.MN+;<u _lu2ZVs#/ke|,E& E#K~W#+zmg');
    define('NONCE_SALT', '|[]yXa3nZj::sIu&n)75KF?#MowtRYWy*YA)sB/NU@(PFam+a;Y_IF8Mt(jC]j');

    /**#@-*/

    /**
    * WordPress Database Table prefix.
    *
    * You can have multiple installations in one database if you give each a unique
    * prefix. Only numbers, letters, and underscores please!
    */
    $table_prefix = 'wp_';

    /**
    * WordPress Localized Language, defaults to English.
    *
    * Change this to localize WordPress. A corresponding MO file for the chosen
    * language must be installed to wp-content/languages. For example, install
    * de.mo to wp-content/languages and set WPLANG to 'de' to enable German
    * language support.
    */
    define ('WPLANG', '');

    /**
    * For developers: WordPress debugging mode.
    *
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    */
    define('WP_DEBUG', false);

    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', false );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'forhisministry.us' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    /* That's all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

  • bt1161
    • Design Lord, Child of Thor

    I had take the .htaccess file out of the root folder. When domain provider added the following .htaccess file to the root folder. It brought hte site down.

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

  • Mason
    • DEV MAN’s Sidekick

    Hiya!

    Sorry, it looks like you're having some trouble. I'm trying to get up to speed, what specific issues are you having?

    Since this is a new WordPress Multi-site, the only thing you should require in your .htaccess file is this:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]

    Are you able to log in to your site at this point? Again, sorry for the delay on feedback. Let's see if we can get this sorted! :smiley:

  • Mason
    • DEV MAN’s Sidekick

    Hiya,

    Looking at your main install the default "About" page is not showing up either. Also, neither the page nor the schooledu site are giving a WordPress 404 error.

    This makes me think it's an issue with Apache's mod_rewrite. Your host should be able to help you with this. It should be set to: "AllowOverride FileInfo Options"

    Here's some more detailed instructions:
    Apache must be configured so that mod_rewrite works.
    1. Make sure a line like the following appears in your httpd.conf LoadModule rewrite_module /usr/lib/apache2/modules/mod_rewrite.so
    2. In the <Directory> directive of your virtual host, look for this line "AllowOverride None" and change it to "AllowOverride FileInfo Options"
    3. In the <VirtualHost?> section of the config file for your host there will be a line defining the hostname. You need to add the following if you want virtual hosts to work properly: "ServerAlias *.domain.tld". Replace domain.tld with whatever your one is, and remove the quotes.

    Again, contact your hosting provider if you need assistance with this one.

    Thanks and good luck! ;D

  • bt1161
    • Design Lord, Child of Thor

    HI James,

    The hosting company was able to get my sub-directory sites up. Yet, My themes aren't being honored. When I log onto my site it only show the page with using any css. Do I have a setting issue or not get something installed correctly? Can you point me in the right direction on what I need to do to get the sub-directories to honor the themes.

    I have enclosed one the links.

    http://forhisministry.us/forum/

  • bt1161
    • Design Lord, Child of Thor

    As a beginner to WPMU, I have learned a great deal. A couple of the web hosting I have domain on do not support WPMU. The companies include the following. http://www.webhostingpad.com and http://www.siteground.com. The other company that I with did have domain with that does support WPMU is http://www.fatcow.com. At Fatcow once the made the changes on the Apache server I was able to create sub directory for the site.

    Now it looks like I have some issues with my WPMU configuration. I not able to get the subdirectories to honor themse.

  • bt1161
    • Design Lord, Child of Thor

    As a beginner to WPMU, I have learned a great deal. A couple of the web hosting I have domain on do not support WPMU. The companies include the following. http://www.webhostingpad.com and http://www.siteground.com. The other company that I with did have domain with that does support WPMU is http://www.fatcow.com. At Fatcow once the made the changes on the Apache server I was able to create sub directory for the site.

    Now it looks like I have some issues with my WPMU configuration. I not able to get the subdirectories to honor themse.

  • Mason
    • DEV MAN’s Sidekick

    Since everything seems to be in the right place, I think this has to be an issue with your .htaccess.

    I looked at the txt you uploaded. Try reverting back to your original .htaccess. Now that we have the server settings correct, they make work.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.