Multi Site moved to subdomain, now wont stop redirecting

So I’ve posted previously about our attempts to run a multisite with domain mapping to another site:

https://premium.wpmudev.org/forums/topic/subdirectory-wordpress-install-issues-with-domain-mapping-forcing-directory-name-onto-parameters?replies=3

We’ve been on this problem a bit long and are now exploring other options. We have access now to a subdirectory site that we want to “install” wordpress multisite to so that it can exist in the root of the site.

Currently, our multisite installation exists in a folder on our main site. The new subdirectory we have now is pointing to that directory.

Below is our structure:

Main blog location: mainsubdomain.main.com/sites/examplesite1/

New: newsubdomain.mainsubdomain.main.com/examplesite1

The issue now is that now after having followed directions to transfer things over to a new domain (http://www.realisingdesigns.com/2010/09/16/moving-the-domain-of-a-wordpress-multisite-install/), the blog main site works (newsubdomain.mainsubdomain.main.com/) but any multisite blog under it infinitely loops into itself.

Below are our settings for reference:

.htaccess:

<IfModule mod_security.c>
<Files async-upload.php>
SecFilterEngine Off
SecFilterScanPOST Off
</Files>
</IfModule>

# BEGIN WordPress
RewriteEngine On
RewriteBase /
RewriteRule ^index.php$ - [L]

# uploaded files
RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

# add a trailing slash to /wp-admin
RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
RewriteRule ^[_0-9a-zA-Z-]+/(.*.php)$ $1 [L]
RewriteRule . index.php [L]
# END WordPress

<Files wp-login.php>
RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}
</files>

<Files wp-signup.php>
RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}
</files>

Relevant wp-config settings:

$table_prefix  = 'wp_';

define('WPLANG', '');

define('WP_DEBUG', false);
/* used for wordpress-mu-domain-mapping */
define('SUNRISE', 'on'); // Add this line here:

/* Multisite */
define( 'MULTISITE', true );
define( 'SUBDOMAIN_INSTALL', false );
define( 'DOMAINMAPPING_ALLOWMULTI', true);

define('FORCE_SSL_ADMIN', true);

define( 'UPLOADBLOGSDIR', 'blogs.dir' );