Dealing with strange character sets in Multidb 3.0.5

After upgrading multidb to version 3.0.5 which is the latest, the older bug is still existing even though using this newer version. The bug is that weird characters appear right after a period or any punctuation marks if there are two spaces between the punctuation marks and the next letter.

How to fix this still?

  • argh2xxx
    • The Incredible Code Injector

    Just to clarify, this only happens on blogs of members that created with older version multi-db. New blogs are unaffected. Unfortunately, the oldest blog which is the main site of everything using buddypress and bp-social theme, and this is affected by strange characters. When a user post something, on the activity page, you can see strange characters appear, but yet on the users’ blogs the strange characters aren’t there.

  • Mason
    • DEV MAN’s Sidekick

    Hiya argh,

    You can change by selecting your db in phpMyAdmin, click on “Operations” at the top and change the collation.

    To check WordPress you will need to make sure your db collation matches what’s in your wp-config.php file. It’s best to get this all matching at the start…trying to change things in an established blog can get messy.

    Hope this helps!

  • ChuckS
    • The Crimson Coder

    Hello,

    I upgraded from multisite and multi-db 3.0.1 to 3.0.5 and got the black diamond question marks on all my blogs. I just checked as masonjames suggested above. This is what I found,

    In db.php 3.0.5:

    if ( is_multisite() ) {
    $this->charset = 'utf8';
    if ( defined( 'DB_COLLATE' ) && DB_COLLATE )
    $this->collate = DB_COLLATE;
    else
    $this->collate = 'utf8_general_ci';
    } elseif ( defined( 'DB_COLLATE' ) ) {
    $this->collate = DB_COLLATE;

    In my wp-config.php:

    define(‘DB_CHARSET’, ‘utf8’:wink:;

    define(‘DB_COLLATE’, ”:wink:;`

    In my MySQL localhost:

    MySQL connection collation: ‘utf8_general_ci’

    In my principle database:

    All tables show : utf8_general_ci

    Except the last summary line says:

    10 table(s) Sum 1,456 MyISAM latin1_swedish_ci 2.1 MiB 73.2 KiB

    What’s up with the latin1_swedish_ci? Is this causing the problem? I can’t find a way to change it. None of the tables include it (I exported all the tables to a text file and did a “find” on “swedish”:wink:.

  • ChuckS
    • The Crimson Coder

    I noticed on some of my sub-blogs, some plugin tables are set to latin or latin1_swedish_ci. Especially one called “subscription”. What would happen if I manually changed all the tables throughout my site to utf8_general_ci?

  • ChuckS
    • The Crimson Coder

    The latin or latin1_swedish_ci is not consistant with the same tables throughout the blogs.

    I also noticed this under the “Variables” tab in PHPMyAdmin:

    character set client utf8

    (Global value) latin1

    character set connection utf8

    (Global value) latin1

    character set database latin1

    character set filesystem binary

    character set results utf8

    (Global value) latin1

    character set server latin1

    character set system utf8

    character sets dir /usr/share/mysql/charsets/

    collation connection utf8_general_ci

    (Global value) latin1_swedish_ci

    collation database latin1_swedish_ci

    collation server latin1_swedish_ci

    Any suggestions?

  • ChuckS
    • The Crimson Coder

    FYI. Update…

    My provider confirmed that the “Variables” settings (above) are the Standard.

    I rolled back the upgrade to 3.0.1. Set all my tables to utf8_general_ci (in the Operations tab for each table in PHPMyAdmin). Still not sure how some tables got changed to “swedish”. Did the upgrade to wp 3.0.5. All looked good. Upgraded multi-db to 3.0.5, got the black diamond question characters back. Reverted back to multi-db 3.0.1 and all was restored.

    I’m now running mulitsite 3.0.5 with multi-db 3.0.1. Will this create any problems for now?

    Chuck S.

  • Mason
    • DEV MAN’s Sidekick

    Hiya Chuck,

    Thanks for your continued feedback. Please use 3.0.4 – you should be fine with this and WP 3.0.5.

    We’ll have Barry take a look at the plugin (he’s been out for a couple days – thus a bit of a delay here).

    Thanks again!

  • ccloskey
    • WPMU DEV Initiate

    I’m having this problem as well. I just upgraded to wp 3.1 — does multi-db 3.0.4 work with WP 3.1? I’d hate to roll back the site upgrade if there’s a solution for this character thing on the horizon, or an easy temporary fix.

  • Shawn
    • The Crimson Coder

    Yes, multi-db 3.0.4 works with WP 3.1 – but I don’t know how stable it’s going to be in the long run. Best to get the charset issues sorted and move ahead, but at this point I don’t know how to get that done. :slight_frown:

  • DavidM
    • DEV MAN’s Mascot

    Hi guys. Thanks for your patience! I’ll go ahead and ping Barry. But just to get a bit more info in the meantime, is everyone having the same trouble as the original poster, where the newly created blogs don’t have character issues but only older ones created using the previous version?

    Cheers,

    David

  • ChuckS
    • The Crimson Coder

    Can’t speak for new blogs. I saw it before any new subscriptions, but all my existing blogs displayed the characters on upgrade. I’m now running Multisite 3.0.5 with Multi-DB 3.0.4.

    Thank you for looking into it!

    Chuck S.

  • ChuckS
    • The Crimson Coder

    Hi,

    I’ve been running Multisite 3.0.5 with Multi-DB 3.0.4 and I’m getting ready to upgrade to 3.1.2. I’m somewhat concerned having read some of the problems on other posts in the forums. Did anyone resolve the character issues after upgrading older blogs?

  • ChuckS
    • The Crimson Coder

    Thanks for checking in. No, not related. I resolved the issue by editing ever post and page on every blog. Tedious, but worked. I’ve since updated to wp 3.2.1 and no problems. But, let’s see what happens when you update the Multi-db 3.0.6 and I install it. :slight_smile: .

    Don’t get me wrong. You guys are great! WordPress is just frustrating at times.

  • Aris
    • WPMU DEV Initiate

    Same problem as ChuckS

    I just upgraded to Multi-db 3.0.6 on a WordPress 3.2.1 install, and all hosted blogs (all in french) are messed up. I have a black diamond question marks fort every accentued charter !

    This affected old posts, new posts are not affected.

    Note – It’s the second problems with UTF-8 occured with an upgrade of Multi-db this year (precedence with version 3.0).

    My database config for UTF-8 is correctly configured, and my datas are this time untouched in MySQL : the problem is in WordPress and created by the Multi-db upgrade…

    I proved to downgrade to Multi-db 3.0.5 : same punition…

    After I downgraded to Multi-db 3.0.4 and it solved the problem, but with old posts… for the new ones, and the edited ones, every accentued charter produce a weid garbage like this : “é” (for “é”), etc.

    Guy, I trusted you when you write in the changelog : “Fixed character set issue”. It’s mu fault.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.