Multidomains Plugin Multisite configuration

Hi, I just installed this plugin and ist says: only compatible with multisite. SO i can not activate it. What is missing?
Can you please help me?
Thanks.