multilingual webshop; dutch okay, but on german the images aren't visible

Hi!

Hope to ask you some questions..... struggeling for 3 days with the same sh..... now....

I have a multilingual webshop; in dutch everything is okay, but on german website the images aren't visible. Everything is the same at both website, I use WPML to translate. The products that are affected I deleted, but I left one as an example.
Look at "Luik" on the bottom
Dutch: https://incosi.com/product_cat/oud-antiek-uniek/page/2/
German: https://incosi.com/de/product_cat/alt-antik-einzigartiges/page/2/

Second, I have to redirect all the products and articles because the urls have changed. I've tried a lot, but now the urls have "product" in the urls...... so be it.
Now I'm trying to redirect everything with the plugin Redirection, but can't seem to be able to get the right cvs format. Do you have any experience with this?

And last: Remove render-blocking JavaScript:
I put this script at the bottom of my functions.php in WP backoffice.
// Remove query string from static files
function remove_cssjs_ver( $src ) {
if( strpos( $src, '?ver=' ) )
$src = remove_query_arg( 'ver', $src );
return $src;
}
add_filter( 'style_loader_src', 'remove_cssjs_ver', 10, 2 );
add_filter( 'script_loader_src', 'remove_cssjs_ver', 10, 2 );

But still I get in The Hub (great tool btw!) that are 41 script blocking... I tried to defer and/or asynchronously load blocking resources but that messes up everything.......

After not been able to work with WP Hummingbird, WP Super cache and W3 total Cache because they conflict (or don't go) with Woocommerce, I found WP Rocket. But in WP Rocket I also can't defer and/or asynchronously load blocking resources without messing it up.....

Hope you can give me some good advice!

  • James Morris

    Hello J.J.,

    I hope you are well today.

    RE: Images...

    When I just checked your site, I'm seeing all images as being displayed correctly. Were you able to resolve this issue?

    RE: product_cat slug in the URLs...

    This is the normal behavior for WooCommerce. To remove this, you will need some special code. Perhaps the following will help? https://gist.github.com/timersys/78a2305d810c27efcb10ce62712d1d95

    RE: Remove render_blocking resources...

    The code you shared will strip query strings from URLs, but will not remove render-blocking resources.

    The following links should help clarify a bit.
    https://developers.google.com/speed/docs/insights/BlockingJS
    https://premium.wpmudev.org/blog/eliminate-render-blocking-issues-hummingbird/

    Hummingbird and WP Super Cache can be used with WooCommerce, but with great care. Where most people have issues is they will enable minification, combination, relocation and deferring on all files and everything goes bad from there...

    When speaking about site optimization, not enough emphasis can be placed on thorough testing! To get the most performance out of your site, while ensuring that everything will work properly, you need to test each file, one at a time.

    * Note: Not all files can be minified, combined, relocated or deferred. By the very nature of JavaScript and CSS written by multiple authors, sometimes incompatibilities crop up when you attempt this. Also, some things just have to be loaded first in order to function correctly. This is a struggle for even the very best sites out there.

    The following, very rough, walk-thru of how to test Hummingbird Minification should give you an idea. The basic gist is to enable the options you want on one file at a time and test. Repeat and test. This is a bit of tedious process, but if you put in the work, the results will be a site optimized for performance while still maintaining the desired functionality.

    https://youtu.be/d5-lO9DOm8g

    Let us know if you have any further questions. We'll be happy to help! :slight_smile:

    Best regards,

    James Morris

  • J.J.

    Hello James!

    Thanks for your elaborate answer. I've put 10 articles that had no picture in the german site in the trash... unfortunately the are completely gone...... at first I could get articles out of the trashcan.....

    There were also a view that weren't visible in german yesterday, but today they were.... So extra bummer that I can't retrieve the ones in the trashcan.....
    This is an example.
    https://incosi.com/product/reageerbuis-xl/ = with picture
    https://incosi.com/de/product/xl-reagenzglas/ = without pictures

    I've tested Hummingbird and WP Super Cache by enabling and disabling every option, didn't work.... But I will try further.....

    Have a nice day!

    Greetings from Holland!
    Janneke

  • James Morris

    Hello J.J.,

    I'm afraid I'm having some difficulty narrowing down the cause of the issues you are seeing. It appears to be an incompatibility between WooCommerce and WPML and not related to our plugins. However, I need to perform some additional tests in order to fully determine where the source of the problem is.

    Support Access has expired on your site and I'm going to need to access your wp-config.php in order to test further. In order to help you better with your issue, would you please grant me access to your site and server?

    Please visit the Contact page and complete the form with the following information:

    Subject: "Attn: James Morris"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    - Admin login:
    Admin username
    Admin password
    Login url

    - Hosting Control Panel Login
    Admin username
    Admin password
    Login url

    ~OR~

    - FTP credentials
    host
    username
    password
    (and port if required)

    Best regards,

    James Morris