Multiple issues with installing plugins on Multisite

I'm having an issue so far with Snapshot and Defender plugins that I'm trying to install on this multi-site. None of the WPMU plugins will install using the dashboard plugin as normal... they give a 500 error when attempting.

So, I manually installed both.

Defender gives a white screen on front and backend of the entire network when attempting to activate it. Not sure why.

Snapshot works and doesn't cause errors, but now since I had to manually install, the WPMU dashboard doesn't show that the plugin is installed, thought the network plugins page DOES. My worry here is that there may be updating issues.

Can you please review and help?

  • Rupok

    Hi Micha,

    So sorry to hear the inconvenience you are having. This is really weird and should not happen. I tried to regenerate all those issues on my test site but I could not regenerate any. So I think, these are your site specific issue.

    Defender gives a white screen on front and backend of the entire network when attempting to activate it

    Just to make sure no other plugin is causing this, can you please do a plugin conflict test? To know more about plugin conflict test, you can check this guide: http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Moreover, can you please turn on debug mode in WordPress and then try to activate Defender again? To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    Past errors here. If the file is very long, paste them to a text file and attach with your reply.

    since I had to manually install, the WPMU dashboard doesn't show that the plugin is installed

    I could not regenerate this on my test site. I manually installed one of our plugins and after activating, the plugin was shown as installed in WPMU DEV Dashboard Plugins section.

    I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know the result of your plugin conflict test and confirm here when you are done granting Support Access. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Nithin

    HI Micha,

    Hope you are doing good today. :slight_smile:

    I'm afraid, the debug logs haven't got attached in your previous replies, you can only attach files in txt formats. Other than that, you'll have to make use of cloud services like Dropbox, Google Drive etc, to share the link to your debug.log file, so that we could give a closer look.

    Please do let us know once you have done that, have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Micha

    hey... I still can't get that to upload. However, I had another issue with the site that leads me to a more likely conclusion. I had another plugin I needed to install and it was also giving a white screen. I traced that issue down to a PHP compatibility issue. Our host is currently using PHP v5.4.13. In this other case, it needed to be at least 5.6 to support the most recent plugin version forcing me to use an older version.

    Can you let me know what the minimum PHP version is for this plugin? I do plan on upgrading this, but I have a bunch of checks to do before I can as this is a new client and we're trying to solve loads of bugs by the previous developer.

    Thanks.

  • Nithin

    Hi Micha,

    Hope you are doing good today. :slight_smile:

    Can you let me know what the minimum PHP version is for this plugin? I do plan on upgrading this, but I have a bunch of checks to do before I can as this is a new client and we're trying to solve loads of bugs by the previous developer.

    If you are looking to upgrade PHP, upgrading to minimum PHP v5.6 would be ideal in general. However, I did check this with the developer, and the plugin should work fine in PHP 5.4 too.

    Please do let us know once you have upgraded PHP, and please redo the debug process, so that we could get the latest log after PHP upgrade. Not sure what could have caused the issue with the file not being uploaded, can you please share the link to the latest debug log using Google Drive, or Dropbox.

    Please do let us know how that goes, have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi Micha,

    Hope you are doing good today. :slight_smile:

    Thank you for sharing the log files, I checked it, and I was able to find the following error:
    [14-Mar-2017 16:19:40 UTC] PHP Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 72 bytes) in /xxx/xxx/xxxxxx/xxxxxxxx.com/xxxxxx/wp-includes/wp-db.php on line 2252

    The above error suggests that your system is running on low memory, and the current memory limit isn't enough to make these plugins work. You'll have to increase your memory limit, so that these plugins works without any issue.
    To increase your memory limit, you'll have to create a php.ini file inside your root directory, and add the following rules to it:
    For eg:

    upload_max_filesize = 128M
    post_max_size = 256M
    memory_limit = 512M
    file_uploads = On
    max_execution_time = 300

    If you aren't able to increase your memory limit, would recommend you to get in touch with your host, in order to increase these values.

    Please check this link for more info:
    https://premium.wpmudev.org/blog/increase-memory-limit/

    If you still have issues even after increasing the memory limit, then please enable support access, so that we could give a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could get this sorted. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.