Multiple product images, drag&drop and auto image deletion

Hi,
I've been reading the posts about adding multiple product images, but haven't found the right solution yet.
Here's where i'm up to, which is not much I guess:
1. Installed this plugin: http://wordpress.org/extend/plugins/drag-drop-featured-image/
2. Installed this plugin: http://wordpress.org/extend/plugins/multiple-featured-images/

Now the thing is I'm still learning WP and I need some guidance. So far I can add 4 featured images on Posts, but not MP products.
My idea is to make use of the two plugins and tweak them to show multiple product images fields in the admin frontend (the one from Tailored Themes) so the user can add up to four product images by just 'drag & drop'. [One problem I've encountered is that the user can upload the images but there will be no way the user will be able to delete them once they delete the product, using unnecessary space in my server which is why I asked a separate question, but if you have the solution to that please post it here], I think I've sorted out how to display those images on the product page once published, so i'm ok with that last part.

I'm a little confused now and do not want to make changes in files that will mess up the code for future updates. Please, if you need something similar, I'm keen to learn and to work with someone who has some experience to develop a plugin or find a solution to this. Any suggestion on where to start or what route to follow, please let me know.
Thanks in advance!!!!

Regards,
Eric

  • aecnu
    • WP Unicorn

    Greetings Eric,

    Thank you for the great input but I am having a bit of trouble getting my head wrapped around where we are with this ticket and what issues remain.

    From what I can tell you have resolved all issues except the one with images remaining after a product has been deleted?

    I further understand that you resolved the multiple images in the products of Market Press? And you overcame this with the Multiple Featured Images plugin?

    http://wordpress.org/extend/plugins/multiple-featured-images/

    Please advise.

    Cheers, Joe

  • Eric
    • WPMU DEV Initiate

    Thanks for the reply Joe and sorry i didn't described the issue clearly.

    So far I can add one product image using Drag & Drop from the front page (using the TT MP Frontend plugin + the Drag & Drop plugin), which is what i wanted.

    Now, there are three more things to resolve.
    1. Using the Multiple featured images plugin, I can add multiple images to Posts, but not to MarketPress Products.
    2. From point one, the Drag & Drop plugin only works for the first featured image, but no for the extra featured image fields added,. (It should work for all the fields). Of course this should be fixed once I can add multiple images to a MarketPress Product (from step 1)
    3. The problem with images remaining after the product has been deleted.

    I'm really keen to work with someone to create a plugin that integrates everything I've pointed out.

    Thanks for your time Joe.

    Cheers, Eric

  • aecnu
    • WP Unicorn

    Greetings Eric,

    Thank you for the detailed information and perhaps @Espen would be interested in working with you on this project since I know he has successfully managed to get multiple images to work on his Market press installation though I do not have any more details then that.

    Alternatively, you could see if there is a developer available at wpmu jobs who could get onto it right this minute.

    In any event I have indeed flagged Espen to this ticket and hopefully we will hear from him otherwise to custom code this up we may have to use wpmu jobs - and I am not a coder myself.

    I will leave this ticket open for a day or two to see if Espen indeed makes his way in here and of course let him speak for himself.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Espen,

    Great question in which only the pixie's and magic dust can possibly explain why you did not get a notification.

    In this case the trigger was @Espen and it should have whipped a notification right over to you sir.

    There are at least three of these that i had sent your way and obviously you did not get them :slight_frown:

    But not for reasons or malfunctions of yours or mine.

    Sincerely, Joe

  • espsjurs
    • The Incredible Code Injector

    Hi again Joe,

    @aecnu : Still not sure how this is working.

    My full name is set to 'Espen Sjursæter', but 'hidden, use my nickname instead'. My nickname is 'espsjurs', not 'Espen'.

    So i guess @espsjurs should work, and @Espen should not. Same as for you; @Joe should not work, but @aecnu should work fine.

    In the profile my first name is set to 'Espen', and 'Display my public name as' is set to 'Espen' - that explain why my posts nickname is set to 'Espen'.

    But, in my wpmudev profile is set to espsjurs as nickname and not working.. So there must be some kind of bug here.

    Espen

  • aecnu
    • WP Unicorn

    Greetings Espen,

    Thank you for your input on this and nowhere except my signature does my name appear - and your screen name @Espen should indeed be the trigger.

    Of course if you like I can have the lead developers/coders look into this a bit more to see what you have got going on with your profile but to the best of my knowledge you are the only one who has reported this type of bizarre occurrence.

    To figure this out one must have sufficient access to your profile in which I do not.

    Let me know if you indeed want me to have them dig into this and in any event have a GREAT upcoming New Year!

    Cheers, Joe

  • espsjurs
    • The Incredible Code Injector

    Hi Joe,

    This might not be a big problem, but if anyone has set the parameters as i have - then they also have this problem. I think you should report it so they can make an query to the database to find all users with this issue. That is the only way to figure out if this is a problem or not.

    If this was my site having this problem, i would have it fixed:slight_smile:

    But for now i want to wish all staff and helpfull users at wpmudev a great new year:slight_smile:

    Yf
    Espen

  • josh
    • Site Builder, Child of Zeus

    @Espen

    Is there a solution for the multiple pictures in marketpress?

    I'm trying to get a neat logical way so that my users will understand it and I won't have to write an entire page long on how to insert multiple product pictures.

    Ideally it would just be in the sidebar of the "add a product" page in Marketpress and all users have to do is drag and drop.

    Wouldn't that be nice?

    Can someone assist with this or refer me to a solution that meets the criteria I mentioned above?

    thank you

  • espsjurs
    • The Incredible Code Injector

    @josh

    Hi there,

    I have created an import function to be able to import more than one image, but this do not solve the problem With view on Product page, and not fixing Your problem.

    I have tested a plugin called 'SB Uploader' where you can set this up by post type. This plugin will give you exactly what you want, but you will have to set you Product template to use the images using the Integration instructions from the plugin description.

    Hope this helps :slight_smile:

    PS! Sorry about the caps, but my browser likes to do this by it self :slight_smile:

  • be
    • WP Core Meltdown

    hi @espsjurs

    I have tested a plugin called 'SB Uploader' where you can set this up by post type. This plugin will give you exactly what you want, but you will have to set you Product template to use the images using the Integration instructions from the plugin description.

    Curious, did you manage to get that to work, I had tried it initially and could not get the subsequent pictures to display front end..?

  • espsjurs
    • The Incredible Code Injector

    Hi @be,

    Did a quick test by first setting SB uploader for 'products' (SB Setup.png). Then added a image in product editor and saved, then copyed the shortcode from the SB uploader to the product description (step 1 and 2), and refresh the product page (before.png and after.png).. Viola :slight_smile:

    Not sure what I do that you don't, or what your issue might be..

  • be
    • WP Core Meltdown

    Thanks so much for doing that, before I delve further, may I ask if you are using Theme - Gridmarket (marketpress) ?

    Also just checking please - more than one picture?
    We could get the initial picture to display but no subsequent uploads ie: product picture 2 or 3

    Only the one that was used as feature image.

  • espsjurs
    • The Incredible Code Injector

    Hi @be

    My active theme at the testsite is Atahualpa, but I did a quick test with Twenty Thirteen, Twenty Fourteen, Pro3 and FullWith (last two from MarketPressThemes.com).

    Gridmarket is not installed on this site, so this is not tested..

    This test was done with two SB Uploaders on the Ballerina shoe, and all of them worked fine. The design is far from superb, but it Works ????

    You can view it live here

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.