Multisite

Hello. I have an issue with setting up Multisite. When I attempt to access the site without "www" I can a page from the site that displays a signup form with the message "The site you were looking for .... does not exist.

Please advise if this can be solved by a plugin or it remains in the setup of the network. Below is the URL.

Respectfully,
Steve

Working URL: http://www.intermediacloud.com/
Issue (without http://www): intermediacloud.com

  • Geoutah
    • Design Lord, Child of Thor

    Hi Steve,

    It seems you set up the site as an add on domain to your main hosting account.
    There are a few reasons you may have this problem. When you configured the install, it is most likely that you left off the www part of the address when installing the initial Wordpress install.

    You can view the address of the root file from your hosts CPanel. It may be as simple as the file misdirecting within the public_html file.

    That's the easiest place to start. Contacting your web host to make sure that the .htaccess file automatically updated when activating MU is also wise.

  • gist
    • Flash Drive

    Geoutah,

    Please see the attached screen-shot as this was setup properly. This site was never setup as a dub-domain.

    Initially I had the plugin "Signup Code" activated and I noticed this issue. In return, I just deactivated the plugin.

    Any ideas?

    Thanks again!

  • aecnu
    • WP Unicorn

    Greetings gist,

    Thank you for bringing up this significant item.

    When creating a MultiSite network the main domain of the network should be just the TLD without anything before it. Your site is believing that you are using the www as a sub domain because that is how WordPress see's that portion as a sub domain - the www - it needs to be configured only intermediacloud.com with no www

    If this has been indeed configured using the www. in the domain name, when you try to creat sub sites the URL will be subsite.www.yourdomain.com and it will not work.

    As shown here in the first graphic in instructions from the WordPress Codex:
    http://codex.wordpress.org/Before_You_Create_A_Network

    Best practice would be to reinstall the MultiSite correctly without the www

    Thank you for being a WPMU Dev Community Member!

    Cheers, Joe

  • magichew
    • Design Lord, Child of Thor

    If you clear your db you'll lose everything content wise, not plugin wise.

    If you want to save all of your content you should go in the Dashboard, Tools and Export everything.

    Then, when you setup your multisite again and go to Dashboard, Tools, Import and choose the Wordpress importer and load all of your content again.

    If you clear your db and then go back to your root domain in your browser you'll get to run the WP install again.
    Your plugins should still be installed but not activated, you can activate them again by going to Dashboard, Plugins and Activate them.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.