Multisite Cloning tool failing, debugging on, message pasted below

Hi, there-- I've got a Multisite setup, and when I attempt to clone the main site, I get a Page Not Found message. When I hit Back, I see the site is not under My Sites, but when I go to My Sites > Network Admin > Sites, it shows up. But clicking Visit or Dashboard results in the Page Not Found page. I turned on Debugging in wp-config and tried again, and I get this message:

Notice: Undefined variable: additional_tables in /mnt/stor9-wc2-dfw1/443341/1026326/www.muvfitnessclub.com/web/content/wp-content/plugins/cloner/admin/cloner-admin-clone-site.php on line 429

Warning: Cannot modify header information - headers already sent by (output started at /mnt/stor9-wc2-dfw1/443341/1026326/www.muvfitnessclub.com/web/content/wp-content/plugins/cloner/admin/cloner-admin-clone-site.php:429) in /mnt/stor9-wc2-dfw1/443341/1026326/www.muvfitnessclub.com/web/content/wp-includes/pluggable.php on line 1179

Thanks so much.

--Jason Andreoni

  • Dimitris

    Hey there jandreoni,

    hope you're doing good and thanks for reaching us!

    It seems there's some conflict with active plugins and/or themes, could you please proceed with a test as described in a nice flow chart here?
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/
    (just scroll down a bit to see the image)

    I look forward for your results on this, as it should narrow down this issue.

    Warm regards,
    Dimitris

  • Dimitris

    Hello jandreoni,

    I just accessed your website and I tried to manually create a new site but after doing so, both backend (/wp-admin/) and frontend pages of the new site weren't accessible.
    I presume this is happening due to some missing DNS records, specifically a wildcard record like
    *.example.com A 192.0.0.1

    https://codex.wordpress.org/Before_You_Create_A_Network#Server_Requirements
    https://codex.wordpress.org/Configuring_Wildcard_Subdomains

    Could you please try to resolve this issue, so a new site is normally accessible and try to clone main blog after that?

    Warm regards,
    Dimitris

  • Adam Czajczyk

    Hello Jason!

    I read this topic and checked your site and I think there are several issues that needs to be handled first before we could get back to the cloning issue. Let me explain :slight_smile:

    There are two errors reported (that you mentioned in your initial post). The first one is a "notice" that states that one database table could not be found. Regardless whether it's important for site performance or not, it's a "notice" and should not break the script. This missing table simply wouldn't be copied but the process should, at least in theory, continue.

    The second error is caused by the debugging itself. When you turned on debugging but did not set it to be logged to the file and not displayed on a screen, any error that's thrown to the page before the rest of WP scripts are executed, would be causing that. It's related to the HTTP rather than WordPress itself. That's a bit counterintuitive but the debug tool actually... breaks the rest of the site.

    Getting back to the first notice though, we can only be sure that it is (or is not) the real reason for the clonning issue when we make sure that the site is working well. The HTTPS issues, the DNS issues etc - these all may be a culprit here.

    Let's then start with SSL.

    The fact that "Privacy Error" comes up on your sub-site suggests that the SSL certificate that you are using is a standard single domain certificate with no wild-card support. Such a certificate will protect "domain.com" but not "sub.domain.com" and other sub-domains.

    Your sub-site is set to work over HTTP so that's fine and if you go to "Network Site -> My sites" and then click on "Visit" link, it opens the site as it should: over HTTP (no SSL) protocol without any errors. The "wp-admin" though opens via HTTPS and that's because the main domain along with wp-admin part is somehow forced and/or redirected to HTTPS. The question is then: how did you set up the HTTPS redirect? I mean:

    - is there any redirect set in .htaccess?
    - and/or were there any additional configuration lines added for this in "wp-config.php" file?

    Any information on this may help.

    The second issue is the fact that sub-sites still don't work. Since you followed an advice given by my colleague Dimitris, it seems that wild-card DNS itself is working because loading the sub-site doesn't return error but just a "coming soon" page. The same happens if you put any non-existing sub-domain in front of your domain. Therefore that part works.

    The page that's served though is a default server page and that means that some more configuration is necessary. In order to tell you how that could be set up though I would need to ask you:

    1) are you using dedicated IP that is assigned only to your domain or is that a shared IP
    2) if it is a dedicated IP, is there any option in your server control panel to set a "root folder" (also known as "document root") for an IP number?
    3) by any chance: are you hosting the site with GoDaddy?

    Let me know please!

    Best regards,
    Adam

  • jandreoni

    Hi, Adam-- Ok, so here are a few answers to your questions:

    - is there any redirect set in .htaccess? - No, there are no redirects set up in .htaccess. The DB has had all instances of "HTTP" with "HTTPS"

    - and/or were there any additional configuration lines added for this in "wp-config.php" file? - No, nothing has been added to wp-config in regards to HTTPS.

    1) are you using dedicated IP that is assigned only to your domain or is that a shared IP. its a dedicated IP.

    2) if it is a dedicated IP, is there any option in your server control panel to set a "root folder" (also known as "document root") for an IP number? No, not possible

    3) by any chance: are you hosting the site with GoDaddy? - No, we are hosting with Rackspace, but the registration/SSL is through GoDaddy.

    From Rackspace's support article:

    Note: Because of the way Cloud Sites works, each site that you need to have managed by the main Multisite installation must be created as an alias. The aliased domain, added through the Cloud Sites Control Panel, must have the primary Multisite domain as its target.

    I'm working my through this now...

  • jandreoni

    Hi, Adam-- So I followed the instructions from Rackspace and added the alias, and now the following new Multisite works under HTTP, but not HTTPS:

    http://loveland.muvfitnessclub.com/

    Cloning still doesn't work, but I suspect it's the HTTPS issue. I'm in contact with the owner of the company to upgrade their cert to handle subdomains and I'll update you once this has happened.

    Thanks!

    --Jason

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.