Multisite Content Copier not working, can't get past step 1

Hi guys,

I'm wondering why this just doesn't work out of the box.
I've got Multisite Content Copier installed on my multisite installation but after opening the Multisite Content Copier panel from Network Admin I can't seem to get past step one. Disregarding of which content type I choose to copy. Anyone?

  • Predrag Dubajic

    Hey Johan,

    Hope you're doing well today :slight_smile:

    I don't remember seeing this issue before and on my installation I'm not having such issues so if you could grant access to the site in question I'll be happy to check this out.

    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please respond in this thread once access is granted.

    Best regards,
    Predrag

  • Predrag Dubajic

    Hi Johan,

    Thanks for granting access, I can see the issue on your site but the strange thing is that there's nothing in console that could tell us what's going on.

    Could you try performing a basic troubleshooting by disabling your other plugins and switching to default WP theme to see if you can get past the first step in that case, that will tell us if there are any conflicts on that end.

    Best regards,
    Predrag

  • Johan

    Hi Predrag,

    I've tried out what you advised on our staging server and that takes me to step 2. Furthermore, I'm able to succesfully copy all matter of posts and other content.
    Also, by starting out with using twentysixteen at first and then re-enabling all the plugins on the staging server gives me no problems. And then, using the same theme & child-theme we use on the live server gives me no problems on the staging server. So, it's safe to assume something else is going wrong here. The two servers are nearly identical, besides a few different server-level settings. Nothing critical.
    I've tried reinstalling Multisite Content Copier in our live environment but trying that returns the following error:
    ------
    Installation of Multisite Content Copier failed. Most likely reason for this are wrong folder permissions of your wp-contents folder.
    ------
    I've checked and double-checked the permissions using the guide on WPMU and I'm sure this is not an issue. Do you have any idea what could be going wrong here, Predrag?

  • Milan

    Hello Johan

    Hope you are well today and won't mind me chiming here ?

    I just took a look at your site and can see that MultiSite content copier is not moving to next step even if I add step 2's query string manually in my browser's address-bar.

    But when I disable all other plugins on your site and keep only MultiSite Content Copier active, I am able to move to next step very easily, please take a look at this snapshot.

    So I suggest you to take down Plugin Conflict test on your end one more time to find culprit. To know more about Plugin Conflict Test please do read this article.( Find flowchart at the end of page )
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Let me know how it goes. :slight_smile:
    Cheers,
    Milan

  • Johan

    Hi Milan,

    Thanks for checking that out but that's exactly the approach I took on our staging server.
    I disabled all plugins, switched themes and then, one by one activated and tried if Multisite Content Copier is still working, and it still worked with all of the plugins enabled. Even with the theme we use on our live environment it still worked on the staging server.
    So on our live server there must be a difference that I have overlooked, this is not a simple plugin conflict, it must be something buried deeper, a plugin config problem or a custom piece of code.
    I'm still very curious to learn what the difference could be that is causing the Multisite Content Copier not to work on our live environment. Do you need any more credentials to debug or see a log file perhaps? Maybe I need to open a private support ticket for this matter. Please advise.

    Regards, Johan

  • Johan

    Hi guys,

    The problem is resolved now. We've updated a few plugins that were minor versions behind the newest version until last weekend, and changed the activation of a few plugins from network wide activation to single site activation through Multisite Plugin Management, regarding WooCommerce related plugins and extensions.
    Luckily it's smooth sailing from now on.
    Thank you for having a look on our live environment Milan, cheers!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.