Multisite Copier can't see forums from bbPress

When I choose to copy custom post types from subsite with ID=4, there're no forums in listed custom post types.
There's a CORS error in the console that Dimitris was able to spot during livechat .
http://take.ms/XbEcv

  • Ash

    Hello Symi

    I have taken a look at your site, and noticed that any ajax request to subsite admin returns 302 error.

    The error usually means that the url is temporary moved. In your case the URL is not moved, but it's getting 302 status. So, would you please contact your host if they have any firewall that is blocking connection to admin-ajax.php? Also, Dimitris found CORS though both sites are same, so I assume there might be some configuration in the server level.

    Please let us know what you hear back from them.

    Have a nice day!

    Cheers,
    Ash

  • Symi

    Hi Ash,

    I just spent a bit of time with the support team from inmotionhosting, who said there's
    1 - nothing in the firewall that would cause this.
    2 - then re-checked the error result interpretation and said Ajax is working as it should (!!)
    3 - told me to go to the guys who develop multisite.

    so - i'm at a bit of a cul de sac here.

    i am contemplating moving my staging site to a baby package on a different host, to run the software and see if that works for me at all.

    i'll report back shortly.

    other than firewall config / server configuration issues, is there anything inside the wp install itself that could cause this? we've disabled every single plugin there, and it's a fresh wordpress installation with the uploads / plugins / wp-content / .htaccess brought in? could i be missing something else than server config?

    thanks!

  • James Morris

    Hello Symi,

    If you are getting this CORS error with a fresh install of WordPress, with nothing else active and using a default theme, the problem is most likely with the hosting configuration.

    However, you could try the following code snippet in your .htaccess file and see if this resolves the issue for you.

    <IfModule mod_headers.c>
      <FilesMatch "\.(ttf|ttc|otf|eot|woff|woff2|font.css|css|js)$">
        Header set Access-Control-Allow-Origin "*"
      </FilesMatch>
    </IfModule>

    Let us know if this works for you and whether you were able to get your other issues resolved.

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.