Multisite Customize Preview Broken

Hey Team,

So I have a brand new Multisite Install and I’ve run into an issue.

when I go to Appearance > Customize it says “Session expired. Please log in again. You will not move away from this page.”

– I’ve tried using another theme (2014) – Still happens

– I’ve tried disabling all plugins (Network Wide) – Still happens

– I’ve tried disabling Varnish Cache for my IP – Still Happens

– I’ve completely turned off varnish and used Apache only (varnish service was stopped) – Still Happens.

– I’ve tried a brand new subsite – Still Happens

It happens across the board, on all sites, on all themes.

And now I’m tearing my hair out trying to work out what could have caused this, so any hints would be appreciated.

Thanks.

  • Anang
    • New Recruit

    Hi @Braydan Willrath

    Thanks for contacting us :slight_smile:

    Sorry you got the problem :slight_frown: Could you try turn on “Cross-domain autologin” on Domain Mapping settings. If it’s still not working could you temporary disable Domain Mapping ? and see if it’s worked ?

    Also could you try switch your themes to other themes ? Just made sure it’s not themes problem :slight_smile:

    Let me know the result :slight_smile:

    Best Regards

  • Braydan Willrath
    • Flash Drive

    Hey Anang,

    So if I turn on “Cross-domain autologin” the page still behaves the same, but when I login (in the preview window) it logs me in and stays logged in, However with it turned off, it just refreshes back to the login screen (in the preview window)

    If I turn off Domain Mapping, it just refreshes back to the login screen (in the preview window)

    And If I Switch to Twenty Fifteen theme, it does the same thing.

    I’ve tried this in different browsers, and in each step I opened a fresh incognito window and re-logged in to the site to ensure no cache or cookie conflicts.

    I’ve granted support access if you wanted to take a look, its not a live site so you are welcome to have a play and figure it out.

  • Braydan Willrath
    • Flash Drive

    I’ve Solved It.

    Even though I’d tried deactivating all plugins network wide, some plugins like to keep working even though they are deactivated, rename the plugins folder to plugins.hold and BINGO it works

    http://codex.wordpress.org/FAQ_Troubleshooting#How_to_deactivate_all_plugins_when_not_able_to_access_the_administrative_menus.3F

    So then I rename it back to plugins and its broken, so I go through one by one and rename the plugins folders to .hold (eg pro-sites to pro-sites.hold) and worked out that WP Super Cache was the Plugin Culprit.

    So I go into plugin setting and turned caching off, it worked, I turn it back on it stopped working, I cleared my cache on all blogs and BINGO we are back in business.

    Please let me know if this thread helped you.

  • Anang
    • New Recruit

    Hi @Braydan Willrath

    Awesome ! you have resolved this issues by yourself :slight_smile: I will give some credit points, because it will help other members when they got the same issues :slight_smile:

    Hope you have a great day :slight_smile:

    Best Regards

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.