Multisite Db import on secondary site only

Hello,

I recently just downloaded a theme to be used on a test site on my network(wp_2_). The theme came with demo content via an XML file. I tried the import method from wp-admin and that didn't work out to well. Probably because it's better to do this with phpmyadmin.

Is there anyway I can import the demo content to my wp_2_wordpress without overriding the wp_wordpress database instead?

Thanks

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hi there, Corbin!

    Typically, installing demo content through WP's Import via xml is the way to go, although some themes might handle it differently than others. This is a site-specific help doc, but usually any time I've imported demo content, it's worked very similar to what they outline here:

    http://themetrust.com/knowledgebase/how-to-import-the-demo-content

    Which theme are you using? Could you provide a link to the place you downloaded it?

    Thanks!

    • Corbin
      • Site Builder, Child of Zeus

      Thanks for the help Michelle,

      That's the method that I was using before. I got the theme from themeforest. It's installed and everything.

      I just deleted the test site, made another one and tried again and I got a fatal error:

      Fatal error: Maximum execution time of 60 seconds exceeded in C:\xampp\htdocs\wordpress\wp-includes\class-http.php on line 1453

      Fatal error: Maximum execution time of 60 seconds exceeded in C:\xampp\htdocs\wordpress\wp-includes\wp-db.php on line 615

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hey there Corbin!

    How high did you set the max_execution time? If you've got the ability to edit your php.ini, that means we can do a lot with your settings. We'll get this sorted!

    Also check your max_time_out settings, you could be timing out too quickly on the upload, if there are glitches or stalls.

    And what's your memory limit? Is it set in more places than php.ini? (Like in wp-config) Let's try cranking all these settings up and seeing if it will push through.

    • Corbin
      • Site Builder, Child of Zeus

      Hey again!

      The memory limit is set to 128M. There is no max_time_out setting that I can find in my php.ini folder. I set the max_execution time to 400 and set_time_limit(400); in my wp-config file. I've still got the same error.

      I then tried without clicking "Download and import file attachments" It worked to a degree, with missing attachment errors, there are still a lot of settings and things like post thumbnails, categories and so on missing.

    • Corbin
      • Site Builder, Child of Zeus

      Thanks for the quick reply.

      I tried your recomendation and the line 1453 error is still happening.

      I forgot to add: I also had another copy of the xml file emailed to me and have been trying that with same problems.

  • Tyler Postle
    • CGO

    Hey Corbin,

    This seems to be an issue with xampp, if you navigate to the line in class-http.php where the error is happening, 1453, then place this line right above it:

    set_time_limit (300);

    It should resolve the problem :slight_smile: increase the time limit if needed.

    Let us know if this does the trick!

    Cheers,
    Tyler

    • Corbin
      • Site Builder, Child of Zeus

      Hey Tyler,

      I got an error when I copied and pasted that in.

      Parse error: syntax error, unexpected 'set_time_limit' (T_STRING), expecting function (T_FUNCTION) in C:\xampp\htdocs\wordpress\wp-includes\class-http.php on line 1453

      Thank you for your help.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.