Multisite Domain Mapping and Multi-Domains workaround

Hello my friends,

I installed a new WordPress multisite.

It is on it's own hosting account as the root site and domain.

It has a dedicated IP address.

I installed and activated Domain Mapping plugin and Multi-Domains for Multisite.

I added the dedicated IP address to the Server IP Address field in Network Settings > Domain Mapping.

I was able to add five domains via Network Settings > Multi-Domains.

Cool.

All five of the domains, and the main network installation domain use the dedicated IP address at the registrar.

...and...

I went to Network Add New Site and the Site Address drop down is there with all five of the domains I added.

Cool.

So I entered the domainname (without the .com) for one of the five, and I filled out the Site Address, Site Title and Admin Email fields (using my network Admin email).

When I clicked Add Site the page refreshed to the site's home page!

I went back to the Network Sites page (using the admin menus) and there was no site.

Semi-uncool.

So I refreshed that page and then went to the Network Add New Site again. Maybe I clicked an ether button instead of the only button on the page [Add Site]... who knows.

Wash, rinse, repeat and I'm at the home page again.

Go back to Network Sites and... no sites.

So I killed every plugin except for the WPMUDEV Dashboard and the two plugins in question here.

I refreshed the Active Plugins page and verified that in fact only these three were active.

Repeat the above cycle again and I'm back at the home page--no sites can be added!

So I de-activated all plugins (ALL).

And I was able to add my sites!

Cool.

Then I re-activated the three plugins and went into Network Settings > Multi-Domains and all five of the domains were there.

Cool.

Next I went to Network Sites and verified each site one by one to make sure the domain names each mapped to the subdirectory under the main network domain. They do.

Cool.

When I go to any of the five domains they all lead to the main network domain!

Uncool.

Here are the settings related to this for all five of the subsites and their domains.

Network Sites > Edit Site > Info

Domain: networkDomain.com/subsiteFolder/

Path: /subsiteFolder/

Update siteurl and home as well is checked

Registered and last updated have dates

Attributes: Public is checked.

Network Sites > Edit Site > Settings

Siteurl: networkDomain.com/subsiteFolder/

...and at the top of each Network Sites > Edit Site page the correct full URL is shown as a giant link:

http://networkDomain.com/subsiteFolder/

If I follow that link then the correct subsite is shown.

But the URL is the ugly full network URL.

Where/how can I tell them two things:

1. When I neter a subsite domain please go to the subdirectory for your subsite please, and

2. When you finally agree to do this please do not show the root/main/network domain in the URL. Please only show YOUR domain name.

So, thank you in advance for the help.

I was able to resolve the failure of adding sites. But now I need help with these last two questions.

Warmest,

Chris

N.B. Never do this the night before you have an appointment to show a client how cool the website network is that you promised them.

  • Vaughan

    Hi @anotheropus

    It looks like you missed the notice at the top of the multi-domains usage page.

    https://premium.wpmudev.org/project/multi-domains/#usage

    Please note: Multi-Domains is for sub domain installations only and will not work well for subdirectory installations.

    You can't use subdir multisite with multi-domains, you have use a subdomain multisite and set up wildcard dns.

    *.domain.com

    So your subsites use the format http://subsite.domain.com

    Hope this helps

  • anotheropus

    Hey Vaughn,

    Thank you for the response.

    I'm not sure I understand it.

    I have only one multisite installed--and it is at the top level domain.

    There is no secondary multisite installed in a subdomain. My head would explode if I tried to manage a multisite of multisites.

    I added three new domains to the multisite today and the same issue happened--when ever I added a site to the network. The Add Site page refreshed to the home page and the site was not added.

    This time rather than disabling all of the plugins I decided to ONLY disable the Domain Mapping plugin and Multi-Domains for Multisite plugins.

    Guess what? It worked! I was able to add the three domains once I deactivated those two plugins (which as I understand it, are supposed to HELP adding sites by adding a site to a domain at the same time).

    So at least now I know how to add a site without fail--even though it seems backwards.

    And once I got the sites in I went into each individual dashboard and set the domain so that all of the sites now resolve to their correct domain name without showing the network site domain--so that's cool.

    Thank you again for the help. I just wish I could add sites with both of these plugins enabled. It may be just one or the other but I need to use the sites and stop troubleshooting the plugins.

    Warmest,

    Chris

  • Vaughan

    Hi @anotheropus

    There are 2 ways to create a multisite (or Network) in Wordpress

    You can have it so that your new sites use a subdir method.

    This is what it looks like you have used.

    So when a new subsite is create, it is appended to your domain.

    http://yourdomain.com = your main site.

    http://yourdomain.com/subsite1 = a new subsite you have created.

    On a subdomain type of network, instead of

    http://yourdomain.com/subsite1

    It creates the new site as a subdomain instead.

    Instead of http://yourdomain.com/subsite1

    It becomes

    http://subsite1.yourdomain.com/

    see http://codex.wordpress.org/Before_You_Create_A_Network

    Hope this explains it a bit more.

    Thanks

  • anotheropus

    Hey Vaughn,

    Thank you for the extra help.

    I will reveal one more layer to the multisite I'm building...

    It will be bi-lingual Russian and English with EN as the default language for each domain.

    So I wanted to get the structure working right and then use the subdomains for the languages.

    E.g. for the main site and all the subsites:

    en.domain.com
    ru.domain.com

    en.subsiteDomain1.com
    ru.subsiteDomain1.com

    en.subsiteDomain2.com
    ru.subsiteDomain2.com

    en.subsiteDomain3.com
    ru.subsiteDomain3.com

    ...which in behind the scenes stacks up to look like this:

    http://networkDomain.com/en/
    http://networkDomain.com/ru/

    http://networkDomain.com/subsiteDomain1/en/
    http://networkDomain.com/subsiteDomain1/ru/

    http://networkDomain.com/subsiteDomain2/en/
    http://networkDomain.com/subsiteDomain2/ru/

    http://networkDomain.com/subsiteDomain3/en/
    http://networkDomain.com/subsiteDomain3/ru/

    I needed to get the framework working such that the WPMUDEV plugins managed getting the subsites into their own domain name positions, then use a plugin to copy the site into two versions, using /en/ and /ru/ subfolders for duplicate languages for each page, post, et al.

    And then I plan to use DNS to point to each language version of the site as a subdomain. This last piece is not critical but it looks good in the URL.

    I needed to get the structure bulletproof so that I can link from one page to another, and within the network to other sites, using the built in editor links so that nothing ever breaks if a page URL changes.

    In this case the main network site's identity will be known on all the subsites but it should not be part of the URL for each subsite.

    N.B. This network is for a group of sites for businessmen in Moscow who desire to market their Russian services to the English speaking world. And once it's up and running I'll try and remember to return here and post more information about the site and the final methods and steps I used to create everything.

    The concept we're using is to create silo sites each focused on one business aspect. Within each silo site there will be pillar content for that business area. It's a whole 'nother post to talk about the marketing values of the silo site approach vs. one site with many pillar content areas. In this context, for this client, it makes sense to break out the pillar content areas into nine unique but related sites within a network for the entire context.

    Thank you again for your help.

    Warmest,

    Chris

  • anotheropus

    Follow up on this... and I need some help from a multisite, subdirectory domain name master :slight_smile:

    I've Googled and WPMUDEved and tried things again and again on the multisite network and athe thre misbehaving sites literally for over five hours and not found a solution.

    The original five sites I added to the multisite, as subdirectories, are working. That is their respective domain names resolve to the subdirectory sits without revealing the network structure.

    E.g.

    http://subdomain1.com resolves to http://subdomain1.com

    ..which is correctly serving and hiding it's true network structure:

    http://domain.com/subdomain1/

    That's great and it works for the first five sites and their domain names.

    However, the last three I added are set up the same way but their domain names do not resolve to their correct subdirectory. These three bad guys will not "map" and anytime the domain name is used it takes the visitor to the top level domain name for the network.

    E.g.

    http://subdomain6.com resolves to http://domain.com

    Fail.

    N.B. I use the term "mapping" here to mean pointing a domain to a directory--and not the sub domain use which seems to have hijacked the universal moniker "mapping."

    THE SETUP

    domain.com
    domain.com/subdomain1/ <-- subdomain1.com works here
    domain.com/subdomain2/ <-- subdomain2.com works here
    domain.com/subdomain3/ <-- subdomain3.com works here
    domain.com/subdomain4/ <-- subdomain4.com works here
    domain.com/subdomain5/ <-- subdomain5.com works here

    domain.com/subdomain6/ <-- subdomain6.com fails
    domain.com/subdomain7/ <-- subdomain7.com fails
    domain.com/subdomain8/ <-- subdomain8.com fails

    THE KEY ISSUE INDICATOR

    All of the sites are listed in:

    http://domain.com/wp-admin/network/sites.php

    ...however, only the first five have a domainname.com listed in the "Mapped Domain" column. The last three have an empty field there. THAT POINTS TO THE PROBLEM--but I can't figure out how and where to MAP these last three.

    All of the sites have the similar Siteurl and Home settings in their respective site setting pages:

    http://domain.com/wp-admin/network/site-settings.php > Settings tab

    I.e.

    domain.com/subdomain1/
    domain.com/subdomain2/
    domain.com/subdomain3/
    domain.com/subdomain4/
    domain.com/subdomain5/
    domain.com/subdomain6/
    domain.com/subdomain7/
    domain.com/subdomain8/

    All of the sites have the similar Domain and Pathsettings in their respective site setting pages:

    http://domain.com/wp-admin/network/site-settings.php > Info tab

    I.e.

    Domain: http://domain.com
    Path: /subdomain1/

    Domain: http://domain.com
    Path: /subdomain2/

    Domain: http://domain.com
    Path: /subdomain3/

    Domain: http://domain.com
    Path: /subdomain4/

    Domain: http://domain.com
    Path: /subdomain5/

    Domain: http://domain.com
    Path: /subdomain6/

    Domain: http://domain.com
    Path: /subdomain7/

    Domain: http://domain.com
    Path: /subdomain8/

    All of the domain names have the correct IP address in the DNS A records.

    As I previously mentioned, the network is installed in it's own hosting account with a dedicated IP address. And the machine works because it works on the first five of the eight but not on the last three.

    So the DNS is covered (and triple checked--all of the nine domain names have identical settings).

    The Sites Settings are covered.

    The Site Settings > Mapped Domain is the problem.

    But I CANNOT find a place to EDIT that Mapped Domain setting!

    Somebody please point me to this simple answer :slight_smile:

    Thank you,

    Chris

  • anotheropus

    I worked through the night on this and I just solved this problem.

    Hopefully this will help others.

    SOLUTION:

    Go to each individual sub site dashboard > TOOLS > Domain Mapping...

    ..and "SET" the domain name.

    [don't "tool" the domain name "set" it--under the TOOLS menu]

    Easy once you know that the "SETTING" is not under SETTINGS--but instead hidden under TOOLS!

    I have some impolite thoughts I'd like to share with the people who decided to hide a setting under the Tools menu.

    Let's revisit this paradigm...

    Dashboard > Tools:
    Import
    Export
    Delete Site

    hmmm... I don't see how Domain Mapping Settings fits here especially when you find all the settings available for most plugins in WordPress under:

    Dashboard > Settings

    General
    Writing
    Reading
    Discussion
    Media
    Permalinks
    PowerPress
    Q & A
    Limit Login Attempts
    Google Analytics
    Languages
    Domain Mapping <--------------- Hey mom! Look where it should go :slight_smile:

    I would add a few more polite smilies to this post in several places but I'm not really Mr. Smilie at this moment.

    Keywords in this post: SETTINGS MENU

    Tags: SETTINGS MENU, Tools-WTF?

    Related Topics: SETTINGS MENU Standards for plugin development.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.