Multisite https on view site links

We have a multisite with a ssl certificate on the primary domain and all subdomains.

The mapped domains do not have ssl certificates. But from the WP Admin area all "view site" links are https://mappeddomain.com whereas we need them to be http://mappeddomain.com but I do not seem to be able to change any settings to achieve https on the admin but just http on the view site links.

What am I missing?

Regards

Drew

  • Adam Czajczyk
    • Support Gorilla

    Hello Drew

    I hope you’re well today!

    For the sub-sites with mapped domain you can’t use connection over “https” if:

    – site’s “forced” to use mapped domain

    – and you don’t have SSL cert for that mapped domain.

    Therefore, if you got back-end access via “mappeddomain” instead of “originalsubdomain” then HTTPS will not work until you actually add an SSL certificate for that “mappeddomain”.

    You can, however, use original subdomain for back-end by setting “Administration mapping” option on “Network Admin -> Settings -> Domain Mapping -> General” page to “original domain” and, optionally, “Login mapping” option to “original domain” as well.

    Then in the dashboard of the sub-site, go to the “Tools -> Domain Mapping” page and in “Domain(s) mapped to” section you’ll be able to switch protocol from “https://” to “http://”.

    This should make back-ends running over original sub-domain and mapped domains on front not be forced to use “https://” for which they don’t have proper certificates.

    The other way around is to actually install certificates for the mapped domains so everything would securely go over SSL connections.

    If you have any additional questions, let me know please.

    Best regards,

    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hi Drew

    Thanks for your reply!

    I think in this case I would like to take a closer look at that. Would you please enable support access to the site so I could check it?

    To do this, please go to the "Network Admin -> WPMU DEV -> Support" page and click on "Grant support access" button there:

    Let me know once it's enabled and I'll see what could be done about the issue.

    Best regards,

    Adam

  • Kasia Swiderska
    • Support nomad

    Hello Drew,

    It looks like this might be a problem with the schema of the mapped domain – right now there is a bug that doesn't allow to switch schema in the mapped domain and that can cause this type of issues.

    When you switch key icon to http it doesn't get save

    I know that this bug is fixed in the upcoming version of the Domain Mapping. We have the beta version, but because it's beta I can't suggest using it on live site. I will attach it in case you would like to try it anyway, to see if it will resolve the issue.

    (make sure you have a backup if you want to try)

    kind regards,

    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.