Multisite Install - New blog creation redirection error

Have network install using subfolders:
http://www.mysite.com/

Adding new site. Site adds fine and shows as a site under the Network Admin. New site messages are delivered; etc.

Only; When I try to visit the site and/or the site's dashboard, I get this error message:
"The page isn't redirecting properly
Firefox has detected that the server is redirecting the request for this address in a way that will never complete.
This problem can sometimes be caused by disabling or refusing to acceptcookies."

I can access a dashboard and the site ONLY through the main site. All clicks on anything on the sub-site get the error.

I have other network installs that I access from the same computer; same browser; same session; that behave properly.

What would cause one site to create this message and another not to?

I have disabled all plugins; moved to twenty eleven and/weaver II themes only; permalinks set to /%postname% on the accessible main site within the network.

  • HunterGatherer
    • Site Builder, Child of Zeus

    Mason,

    What let you know it was in the .htaccess file?

    I know it does permalink rewrites. Should I have been able to guess it from the error message? I didn't make the connection.

    Does it mean that whenever you see a "redirection" addressing error, the place to look first is .htaccess?

    Thanks again,

    HG/mws

  • Mason
    • DEV MAN’s Sidekick

    Hiya,

    Honestly you'd checked off a lot of the things I would look for in your first post. And when it's an issue across the board (meaning every sub-site is having the same issue) there's only a couple places to look. The .htaccess file and having mod_rewrite enabled in apache are the two most common culprits.

  • Patrick
    • WPMU DEV Initiate

    Hi,

    I am experiencing the same issue. Fresh install, dealt with cookies and still experience redirect loop. I have no idea how to tell if I have the correct .htaccess though. I assumed it was correct as it was supplied directly from the "Enabling the Network" page of my install.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /sandbox/
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) home/content/92/9207692/html/sandbox/$2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ home/content/92/9207692/html/sandbox/$2 [L]
    RewriteRule . index.php [L]
    </IfModule>

    # END WordPress

    It is installed in its own directory, not in the root. Don't know if that makes a difference.

    Thanks for any help.
    Patrick

  • Patrick
    • WPMU DEV Initiate

    Hi again,

    Also, I can get to the new site to view it but it has no styling. If I try to go to "New Post" or "Manage Comments" it gives the following error.

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Thanks

  • Patrick
    • WPMU DEV Initiate

    Okay. I found a solution. Hope it helps someone else.

    Remove the absolute paths in bold from these two lines.
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) home/content/92/9207692/html/sandbox/$2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ home/content/92/9207692/html/sandbox/$2 [L]
    They should look like the following.
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]

    Happy days. :slight_smile:
    Patrick

    P.S. This is for a sub-directory install.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.