Multisite Mapping Domain Bug infinite loop redirection wp-login

Hi !
I don't understand.
I have read every posts about infinite loop redirection but I can't manage to solve this problem.

So, I have :
- wp multisite with many wpmu plugins installed.
- everything was ok until I install Mapping Domain.
- My domain names are all correctly set and linked with my subsites.

-> "myfirstdomain" is 'linked' with "myfirstdomain.ca" (and I am admin).
-> I can login with maindomain.com/myfirstsubdomain or http://myfirstdomain.ca
That's OK.
I am connected and I come on the frontend dashboard.

Now I'm trying to go in my admin dashboard I'm always redirected on http://myfirstdomain.ca/wp-login.php?redirect_to=http%3A%2F%2Fmaindomain.com%2Fmyfirstsubdomain%2Fwp-admin%2F&reauth=1

Impossible to go in the admin area...

I have tried with 3 browsers, same problem.
I have tried to clear cookies, the same...

in wp-config.php, I have tried with and without comments but the same :
define( 'SUNRISE', 'on' );
define('ADMIN_COOKIE_PATH', '/');
// define('COOKIE_DOMAIN', '');
define('COOKIEPATH', '');
define('SITECOOKIEPATH', '');

Maybe there and issue with wp-rocket cache (I have tried to empty it too) or with config in htaccess ???

Thank you in advance for your help !
And, of course, have a good day !

  • Ash
    • WordPress Hacker

    Hello @boll

    Welcome to WPMU community!

    I hope you are well today and thanks for asking the question.

    Did you enable cross domain login from Network Admin > Settings > Domain mapping? Would you please post a screenshot of that page?

    And would you please grant support access from your Dashboard > WPMU DEV > Support > Support Access so that I can check?

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Cheers
    Ash

  • Ash
    • WordPress Hacker

    Hello @boll

    Please check now. I have fixed it by selecting Network Admin > Settings > Domain mapping > Administration mapping > "domain entered by the user".

    Hope it helps :slight_smile: Please feel free to ask more question if you have any.

    Cheers
    Ash

  • boll
    • Design Lord, Child of Thor

    Good Job @Ash !

    Yes please 2 quick questions
    1) Could you please tell me why this setting was the origin of the redirect loop ?
    2) When I grant you access via Wpmu dashboard, then you have network admin capabilities ? (I saw that you have created an user, but I would be sure there is no 'hole' in my WP network...)

    Thank you again Ash

  • Ash
    • WordPress Hacker

    Hello @boll

    Thank you! :slight_smile:

    1. Well, the issue was logical. For example,

    Network: network.com
    Subsite: network.com/subsite
    Mapped domain: subsite.com

    The settings was:
    Administration mapping: original domain
    Login mapping: mapped domain

    See, when you login it uses subsite.com to set cookie, and when you go to admin end, it uses network.com. But there is no cookie set for network.com as you used original domain for administration.

    In my opinion, the better option is to use domain entered by the user for both settings.

    2. Yes, when you enable support access, we get the super admin privilege. I needed to create an user (sorry I forgot to mention) for testing purpose, because as a super admin, I always have access to all subsites. I just wanted to test as a stand-alone that particular site user.

    Hope it helps :slight_smile: Please feel free to ask more question if you have any.

    Cheers
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.