Multisite network admin url redirects to home page of main site

When we log in with superadmin user id and password and click for network admin dashboard, it instead redirects to home page of main site.

Kindly help me fix this issue.

Since I want to keep the site and it’s login credentials, I would prefer to send by email.

  • James Morris
    • WordPress Enthusiast

    Hello Pooja,

    I hope you are well today. We will be happy to help you with your issue.

    We have the option of Support Staff Login here, which us enables us to login without the need for you to post admin login credentials here on the public tickets. In order to help you better with your issue, would you please grant me access to your site?

    You can learn how to grant WPMU DEV Support Access at the following link:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please reply back here once you’ve enabled access so I will be notified.

    Best regards,

    James Morris

  • Pooja
    • Site Builder, Child of Zeus

    Dear James,

    Thank-you for your reply.

    However I may inform you that since I m not able to login to network dashboard as it’s link redirects to home page of main site, instead to allow me to network admin page, I can’t allow support access for you guys. I can only login to dashboard of main site and not of network admin.

  • James Morris
    • WordPress Enthusiast

    Hello Pooja,

    I sincerely apologize for the delay. I didn’t get notification of this post for some reason.

    Since you cannot login to enable Support Staff Login, would you please grant me access to your site and server?

    Please visit the Contact page and complete the form with the following information:

    Select “I have a different question” from the drop-down box.

    Subject: “Attn: James Morris”

    In the Message box, please provide the following:

    – link back to this thread for reference

    – any other relevant urls

    – Admin login:

    Admin username

    Admin password

    Login url

    – Hosting Control Panel Login

    Admin username

    Admin password

    Login url

    – FTP credentials

    host

    username

    password

    (and port if required)

    Best regards,

    James Morris

  • James Morris
    • WordPress Enthusiast

    Hello Pooja,

    I apologize for the delay in resolving this. I’ve been doing some researching and found the code that’s causing the redirection, but the reason that code is present is a mystery to me as of yet.

    In your wp-config.php you have the following line:

    define( 'NOBLOGREDIRECT', 'http://www.yourdomain.tld' );

    When I comment out this line, the site redirects to http://yourdomain.tld/wp-signup.php?new=yourdomain.tld and generates a 500 Internal Server Error when I click on your Network Admin Dashboard link.

    Can you shed a little light as to why that line was in your wp-config.php? Do you know what is causing your site to want to redirect to the signup page when clicking Network Admin?

    Since I’m unable to access your Network Admin Dashboard, I’m a little bit limited in what I can find. If you want, I can perform a plugin conflict test. But, this would require a short window of time where certain functionality of your site may be lost. If you would rather not do this on your live site, would you please setup a staging site and grant us access to the FTP of that site as well?

    Best regards,

    James Morris

  • Pooja
    • Site Builder, Child of Zeus

    The chronology of this website may give some clue.

    Earlier, this site was hosted on server 1 and I created Multisite WordPress with the same name at server 2 without changing to DNS of server 2. There after, I designed the server 2 site by changing host file of local machine by adding I.p address of server 2 therein.

    We requested the hoster to create a temporary url so that we can do work anywhere apart from the above local machine. But they couldn’t do so.

    The issue in question cropped up after a short while. However, upto few weeks back, on local machine, there was no issue related to network admin dashboard.

    When we reported this issue to hoster as well as wpmu forum, they told that this is because the DNS are not updated. So, we had updated the dns. However, the issue persists.

    So, coming to your query related to addition of line wp- config file, it may be done by hoster to create temporary url, as mentioned above.

    As regards the testing of plugins conflict, you may go ahead without worrying about dysfunctionality of site for a short while.

    As regards ftp details, I have already mailed all the hosting details as well. You may kindly use them to do the needful.

    thanks for your efforts,

    Pooja

  • Patricia BT
    • Connector

    Hi again,

    you say “So, we had updated the dns. However, the issue persists.”

    When did you change it? Do you know it may take a few hours (up to 24), for DNS changes to propagate… maybe your device is still looking for the site at the old DNS.

    If not this issue, I would first go look into the database (via the host phpMyAdmin tool), and look in the table wp_options, if those 2 fields are correct with your address:

    – siteurl

    – home

  • Pooja
    • Site Builder, Child of Zeus

    Dear James,

    So far the issue is not fixed. You asked as to why the code of redirects were added (define ‘NOBLOGREDIRECT’:wink:. This was added to fix the following issue-

    “Error :. Cookies are blocked or not supported by your browser. You must enable cookies to use WordPress.”

    I hope this insight shall help.

    I would be grateful for your efforts to do resolve the issue.

    I would request any other support person to kindly help me.

    With regards,

    Pooja

  • James Morris
    • WordPress Enthusiast

    Hello Pooja,

    I hope you are well today.

    I’ve found the problem. In your wp-config.php, you had the following line defined without the www in your domain:

    define('DOMAIN_CURRENT_SITE', 'yourdomain.org');

    I’ve changed it to the following:

    define('DOMAIN_CURRENT_SITE', 'www.yourdomain.org');

    This has fixed the issue with your not being able to login to the Network Admin of your site.

    Let us know if you have any further questions. We’ll be happy to help! :slight_smile:

    Best regards,

    James Morris

  • Pooja
    • Site Builder, Child of Zeus

    Dear James,

    Thank you very much for your successful efforts. I am grateful.

    Some of remnant issues have come to my notice:

    1. Domain.Tld/wp-admin leads to sign up page whereas http://www.domain.tld/wp-admin leads to admin login page.

    2. Even with super admin, every subsites dashboard needs me to sign in again with the same login credentials.

    Will be grateful again for solution to above issues and also if website name is removed from your earlier post for privacy purpose.

    With regards

    Pooja

  • Pooja
    • Site Builder, Child of Zeus

    Hi Ivan,

    Thank you for resolving the issue but that has only its one part. Its second part still remains unresolved – I need to login again for sub-site admin. (Even with super admin, every subsites dashboard needs me to sign in again with the same login credentials.). Please also look into it.

  • James Morris
    • WordPress Enthusiast

    Hello Pooja,

    I attempted a number of wp-config.php hacks to get single sign on working on your site. Because of your particular configuration, none would work.

    I installed our Domain Mapping plugin and only enabled the option Cross-domain autologin. After doing this, you are now able to access the Admin Dashboard of all subsites without the need to login again.

    If you would rather not run this plugin, let me know. We’ll keep digging and see if we can come up with another solution for you. But, as of right now, this is working for you.

    Best regards,

    James Morris

  • Lindeni Mahlalela
    • Recruit

    Hello Pooja.

    I hope you are doing great today. As I was going through some threads, I noticed that this thread is still open and we didn’t receive a response from you since my colleague James has made those changes he outlined above.

    I was wondering if you found James’ solution useful or not. Is it still working fine for you? I have noticed that there are no strange redirects on your admin side (I was just checking the urls, didn’t login) and that is a good sign that things are working as they should. Please let us know if you think otherwise or you are experiencing the same issues and we are always happy to help. :slight_smile:

    I hope you enjoy day further.

    Cheers,

    Mahlamusa

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.