Multisite privacy default option not applied to sites

Hi,

When I apply the default privacy setting to all the sites in our WP network, the setting is not applied at all, i.e. no change in the privacy setting of the individual blogs.

I've tried all settings, but applying the default doesn't seem to have any effect. I've noticed that this IS the case when I have manually changed the privacy setting of a blog prior to applying the default from network dashboard.

I hope you can reproduce this behaviour and that you can fix this?

Kind regards

  • Ash
    • WordPress Hacker

    Hello @Leerpodium

    I have just tested in your site and it worked perfectly fine as it should. Maybe I am missing something.

    Would you please let us know a step by step procedure so that we can test again?

    What I did is, first change settings from http://ahk.leerpodium.nl/huibcluistra/ site and then from network admin I just updated. And all of http://ahk.leerpodium.nl/huibcluistra/ are changed as per default value of network.

    Please suggest.

    Cheers
    Ash

  • Leerpodium
    • Flash Drive

    Ok, in order to replicate this problem, please follow these steps:

    1. Login to ahk.leepodium.nl
    2. Create a new test site
    3. In the new site go to settings and confirm that site visibility is "allow search engines to index this site"
    4. Go to network admin > network settings and update all sites with the setting "Only allow logged in users to see all sites"
    5. Go to settings of the test site you created and confirm that visibility settings have not changed: the update has not been applied to the newly created site visibility settings

    I have tested this with Chrome and Firefox.

  • Michael Bissett
    • Recruit

    Hey @Leerpodium,

    Oddly enough, I went through all of those steps, to the letter, inside of Google Chrome, and I found that the settings were updated without issue. You can verify this by looking at the settings for the sub-site I created:

    http://ahk.leerpodium.nl/meintestsite/

    In regards to the browsers you mentioned, are they up-to-date, and have the browser extensions been disabled? It'd odd that this seems to be only showing up on your end presently, and I'd definitely like to get this resolved for you. :slight_smile:

    Please advise,
    Michael

  • Michael Bissett
    • Recruit

    Hey @Leerpodium,

    Hmm... after some further testing (both on your Multisite, as well as my test Multisite), I've found some interesting results. Apparently, even when the network default privacy is set to:

    "Only allow administrators of a site to view the site for which they are an admin."

    When I create a new blog, the setting for the blog inside of Settings -> Reading is:

    "Allow search engines to index this site"

    The reason why you're not seeing this right away on your Multisite is due to the settings for the blog that you chose for this particular template (the template blog is set to "Only administrators can visit - good for testing purposes before making it live"). But, once a post gets created, that's when the setting changes to "Allow search engines to index this site".

    In short, by default, the "Only allow administrators of a site to view the site for which they are an admin." setting isn't being respecting when creating a new site from the admin side.

    I've notified the developer of this, so we can look into this further. :slight_smile:

    Kind Regards,
    Michael

  • Leerpodium
    • Flash Drive

    Thanks for looking into this! So we have been able to reproduce this:
    (quote from Michael Bissett)

    "once a post gets created, that's when the setting changes to "Allow search engines to index this site".

    Is there a way to avoid this in the future?

  • Leerpodium
    • Flash Drive

    Thank you for your reply. However, I do not think the following is a feature:

    1. I create a new blog based on a template with privacy setting "only admins"
    2. The new site gets the template's privacy settings (so far so good...)
    3. I create a first post on the new blog
    4. I visit the new blog (front end)
    5. I go back to the dashboard > settings> the privacy setting of the new site has been set to "allow search engines to index"

    I have extended WPMU dev support access on our network site at edithstein.leerpodium.nl. can you reproduce this bug/feature?

    TL;DR: new site visibility is set correctly initially from template, but setting is reset to visible after publishing first post.

  • Leerpodium
    • Flash Drive

    PS. My latest info was not completely correct. The template privacy setting is not "only admins" but "only registered users". But still, you should be able to reproduce this feature/bug? I've corrected the description:

    1. I create a new blog based on a template with privacy setting "only members"
    2. The new site gets the template's privacy settings (so far so good...)
    3. I create a first post on the new blog
    4. I visit the new blog (front end)
    5. I go back to the dashboard > settings> the privacy setting of the new site has been set to "allow search engines to index"

    Can you reproduce and maybe solve this? We use the combination of templates and privacy options for student portfolio's and because of this bug/feature, information that was supposed to be shielded from the www was indexed by a.o. Google. We would expect the privacysetting from the template the remain after creating the first post...

  • Patrick
    • Support Monkey

    Hi there @Leerpodium

    I hope you're well today!

    I just tested the workflow you described above and can reproduce the issue.

    When the new site is first created from a template, the privacy setting is correct. However, once a new post is published, the setting reverts as you describe.

    @Ignacio & @S H Mohanjith could you guys take another look please? Thanks!

  • Leerpodium
    • Flash Drive

    Sorry to bother you again, but I still have problems applying the default privacy setting to all sites within one of our networks, after updating to the latest version.

    Hopefully you will be able to reproduce / solve this issue:

    1. Go to site "test" at ahk.leerpodium.nl and verify privacy setting is "index this site" (direct link: http://ahk.leerpodium.nl/test/wp-admin/options-reading.php)

    2. Go to network settings and apply default privacy setting "Only allow logged in users to see all sites" to all sites within the network

    3. Go back to site test and confirm that pirvacy setting remains unchanged.

    We would expect the privacy setting of the site test to be updated with the default setting?

    I have extended WPMU dev support access on our network site at ahk.leerpodium.nl.

    Thanks in advance!

    Floris

  • Leerpodium
    • Flash Drive

    I'm afraid this issue is still unresolved. I have just installed a new wordpress network (an hour ago) with the multisite privacy plugin. The 'apply default option to all sites' functionality did not work again. I had to manually set the privacy setting for the specific website, even though I had selected the "Update All Sites" option from network.

    In short: default settings are NOT applied to sites from the network admin options.

  • Tyler Postle
    • CGO

    Hey there Leerpodium,

    Hope you're doing well today!

    This seems to work fine on my install. It does take a couple minutes for it to apply throughout my network though. Your setting still haven't been applied yet?

    It looks like your support access has expired, I don't see any sites with it granted. Do you mind re-granting that? Then we can take a closer look :slight_smile:

    You can grant support access via admin dashboard - WPMU DEV > Support > Support Access > Grant Access.

    Look forward to hearing back Leerpodium!

    All the best,
    Tyler

  • Leerpodium
    • Flash Drive

    ok, access granted to a minimal installation. See if you can apply a diiferent site visibility to the main site through network admin.
    Or... maybe this script does not apply the default setting to the main site, only to other sites within the network?

  • Michael Bissett
    • Recruit

    Hey @Leerpodium,

    I'm able to change the privacy settings for the main site if I go to Settings -> Reading inside the Dashboard for that site, but as far as the "Update All Sites" option inside the Network Dashboard is concerned, it's not designed to change the privacy setting for the main site.

    Was the main site the only remaining concern here? As my colleague @Tyler Postle mentioned earlier, it can take a few minutes for the changes to be applied to the other sites in the network.

    Please advise,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.