Multisite Privacy Plugin Caught in a Groundhog Day Loopedy Loop...

Hello support, I hope this finds you doing well :slight_smile:

OK, so I'm having a simular problem that another member had some time ago:
https://premium.wpmudev.org/forums/topic/multisite-privacy-stuck

So I activate plugin, set my default settings, and then saved and it went through an 'Applying to sites xx of 12' screen and then returned to the dashboard. All appeared well... until...

So I clicked on a menu link (can't remember which one it's not relevant) and it went right back into the 'Applying to sites xx of 12' screen. ok... strange... So then I click on a different linke and... Same Thing...

Luckily I took a full site backup right before activating the plugin, cause I always do :slight_smile: and all is well. I uninstalled the plugin, re-installed it and re-activated it and BAM 'Applying to sites xx of 12' screen pops up again...

So now I have deactivated the plugin and I went into the database to clean out any rouge tables and I could not find any.

Can you please tell me what all data tables I might need to look for or what script it's calling when you save your settings with the 'Save to all Sites' box checked? If I activate the plugin it goes right into the 're-saving' process again... :slight_frown:

Thanks for your help!

  • Adam Czajczyk

    Hey James,

    I hope you're well today and thank you for your question!

    I've run through this other thread that you've mentioned. Have you tried to remove 'privacy_update_all_blogs' cookie? Also, it would be good to disable caching plugin (if you're using any) and empty all caches prior to enabling this plugin and configuring it.

    As for tables. Please search your "wp_sitemeta" table for this string: "%privacy%" as a "meta_key". This should bring you all the settings, including available settings as a serialized array.

    I hope that helps!
    Cheers,
    Adam

  • tankbay

    Hello Support,

    I have the same symptoms. If I install Multisite Privacy it goes into a loop saying it is updating sites before bringing me back to the Network Settings page, regardless of what menu item I click on the dashboard.

    At first I thought this was a clash with other plugins, but i have even tried deactivating all others and it still does it. I looked for those fields in the DB, but changing them made no difference. i have even deleted them and reinstalled, but as soon as I activate it the loop begins. As soon as I remove the plugin the behaviour stops. I'm not sure what @SD meant by updating each subsite.

    What would you recommend?

    Thanks,

    Tankbay

  • Adam Czajczyk

    Hello Tankbay,

    I hope you're well today!

    By "updating each subsite" SD meant applying privacy settings on "per-site" basis by going to each site's dasbhoard "one by one", I think. Have you already tried this?

    I'd like to ask also to start new threads of your own in future, even if the issue would be the same or very similar to already existing one. Please note that the last post here was on June 6th and in case of some plugins this may mean one or more updates that may change a lot :slight_smile:

    That said, let me know please if you tried applying settings not "in batch" but by single subsites and if it worked!

    Cheers,
    Adam

  • tankbay

    Hi Adam,

    Thank you for your comments.

    I do not know what you mean by applying per site as the problem occurs as soon as you click network activate.

    Unfortunately I have installed an open source plugin from JonRadio as a temporary solution, as this seems to work fine. Multisite Privacy is more versatile as it can be set to automatically apply security settings on all new sites on the network, but I just do not have any more spare time to look at this at the moment.

    Regards,

    Tankbay

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.