Multisite Privacy plugin updated and now the add password option fails.

When I upgraded my server to 3.81 a few weeks ago the only plugin that would not automaticallyupgrade was "Multisite PRivacy"

Yesterday, I decided to resolve that issue and removed the plugin in the backend and reinstalled the newest plugin.

Now the plugin appears to be working correctly, by the sites that had been using the "password" option can not log in with the simple password.

Any ideas?