Multisite Privacy stuck

I put Multisite Privacy on my multisite with MPMUDev. I only have MPMUDev plugins and themes on this site. I went in and set the network settings. When I applied the settings across all sites I got the "Applying to sites, please wait..." stay on my screen all day. The only way I can get this off my site is to clear the days cookies in my browser and delete the multisite privacy plugin or I can not get back into my network dashboard. I tried reloading and trying it again with the same issue. Any ideas?

  • jay_smull

    Using Google Chrome - checked in IE
    1. Using latest version - Yes

    2. only activated plugins where - admin ads, admin footer text, admin help content, admin message, admin panel tips, bbpress, membership premium, musupport system, pro sites, q&A, random theme on signup, remember me checked, remove permalinks menu item, select language at signup, set password on wordpress multisite blog creation, whmcs multisite provisioning, whmcs wordpress integration, who sees ads for wpmu, wpmu dev dashboard, wpmu dev videos

    3. Deactivating all plugins - yes

    4. reactivating privacy plugin - yes

    5. went to settings and clicked on apply to all sites - started at 3:08: page says "Applying to sites, please wait... 0 of 1 sites updated"
    3:25: still at the same screen.

    6. re-login in to wp-admin: takes me to one of my sites instead of the admin dashboard

    7. go to network admin: wp-admin/network/ now says "Applying to sites, please wait... 0 of 1 sites updated"

    8. going into cpanel to delete plugin again

    9. while in cpanel checked error log - Shows no errors.

    10. Going to uninstall WordPress multisite and re-install - Yes

    11. re-uploading wpmu dashboard - yes

    12. installing Multisite Privacy - yes

    13. activating multisite privacy - yes

    16. going to Network settings - clicked on update all sites again and saving changes

    17. that was with only the / site

    18. adding a test site - yes

    19. going to network settings - clicked on update all sites again and saving changes
    4:29 "Applying to sites, please wait... 0 of 1 sites updated"
    4:36 still same message.

    20. all same issues with no plugins both on IE and chrome, re-installed WordPress multisite and privacy with same issues.

  • PC

    Hiya,

    Greetings and thanks for posting back with detailed info.

    I just tried to replicate the same issue on my lab site and created 50 demo sites as subsites and then applied a change to the privacy settings and updated the network, and it just took it 3 seconds to update them all.

    So, the problem might be with the hosting somewhere. Can you please check your server error logs and post them here so that I can consult with our lead developer on what the issue might be ?

    Please advise.

    Cheers, PC

  • jay_smull

    I did find the errors in the wp-admin. had to search for the right error-log. Here is what it says:

    [03-Mar-2013 22:21:46 UTC] WordPress database error Unknown column 'active' in 'where clause' for query UPDATE wp_blogs SET public = '1' WHERE blog_id != '1' AND active = 1 AND deleted = 0 AND spam = 0 made by do_action('update_wpmu_options'), call_user_func_array, additional_privacy_site_admin_options_process
    [03-Mar-2013 22:23:54 UTC] WordPress database error Unknown column 'active' in 'where clause' for query UPDATE wp_blogs SET public = '1' WHERE blog_id != '1' AND active = 1 AND deleted = 0 AND spam = 0 made by do_action('update_wpmu_options'), call_user_func_array, additional_privacy_site_admin_options_process
    [03-Mar-2013 22:28:51 UTC] WordPress database error Unknown column 'active' in 'where clause' for query UPDATE wp_blogs SET public = '1' WHERE blog_id != '1' AND active = 1 AND deleted = 0 AND spam = 0 made by do_action('update_wpmu_options'), call_user_func_array, additional_privacy_site_admin_options_process
    [03-Mar-2013 22:28:53 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/nssfinco/public_html/wp-content/plugins/sitewide-privacy-options/sitewide-privacy-options.php:101) in /home/nssfinco/public_html/wp-content/plugins/sitewide-privacy-options/sitewide-privacy-options.php on line 119
    [03-Mar-2013 22:34:30 UTC] WordPress database error Unknown column 'active' in 'where clause' for query UPDATE wp_blogs SET public = '1' WHERE blog_id != '1' AND active = 1 AND deleted = 0 AND spam = 0 made by do_action('update_wpmu_options'), call_user_func_array, additional_privacy_site_admin_options_process
    [03-Mar-2013 22:34:32 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/nssfinco/public_html/wp-content/plugins/sitewide-privacy-options/sitewide-privacy-options.php:101) in /home/nssfinco/public_html/wp-content/plugins/sitewide-privacy-options/sitewide-privacy-options.php on line 119

  • PC

    Greetings and thanks for being a great community member.

    We haven't heard from you on this one for long and I am doing a regular followup to see if there is still something we can assist you on this thread.

    Just to manage the support issues more efficiently, I am marking this thread as resolved for now however this is not being done to avoid your questions in any ways.

    Please feel free to mark this is "Not resolved" in case you have further questions and we would be back on it.

    Thanks a lot for being with WPMU DEV.

    Cheers
    PC

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.