Multisite Problems/local host server error

Hi there, I have got an existing multisite installation that I have broke in the process of trying to remove it and now cannot install the wpmudev plugin (or anything else!).
I have followed the instructions for removal on the wpmudev site but when I apply them I get a range of odd behaviour and when I then reverse the instructions to essentially take it back to a multisite I get a floating "f" right at the top of the page, and when I go to the plugin page on the network dashboard I am told that the server cannot communicate with the local host.
I don't know what to do next? I desperately need the multisite installation removed because it is playing havoc with the paidmembershipspro plugin (which is rather hopeless in itself!) and my customers are going around the bend!

The site is:
http://www.brocantehome.net

I currently can't grant you access to the site via the plugin but am of course happy to provide my login details.

Thanks

Alison May

  • Predrag Dubajic

    Hey Alison,

    Hope you're doing well today :slight_smile:

    Can you tell me which guide did you follow?
    This one perhaps https://premium.wpmudev.org/blog/uninstall-multisite/ ? Did you made sure none of the steps are missed?

    I have followed the instructions for removal on the wpmudev site but when I apply them I get a range of odd behaviour

    Would you mind providing some more info about this, what exactly is this odd behaviour, can you give us some examples?

    Best regards,
    Predrag

  • Alison

    Good morning Predag, thanks for your prompt reply.

    This is the current error message in the wordpress dashboard:

    f
    Warning: Cannot modify header information - headers already sent by (output started at /home/brocante/public_html/wp-config.php:1) in /home/brocante/public_html/wp-content/plugins/wordpress-seo/admin/class-admin-init.php on line 84

    Warning: Cannot modify header information - headers already sent by (output started at /home/brocante/public_html/wp-config.php:1) in /home/brocante/public_html/wp-includes/pluggable.php on line 1171

    This is the error on individual blog post pages:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@brocantehome.net and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    I also cannot find the following tables in myphp

    wp_registration_log
    wp_signups
    wp_site
    wp_sitemeta

    Does any of this make sense?

  • Predrag Dubajic

    Hi Alison,

    Since the error is related to your SEO plugin can you start by going to wp-content/plugins/ folder and rename wordpress-seo folder so it get's deactivated and see if your site loads after that.

    I also cannot find the following tables in myphp

    Hmm, all but wp_signups are multisite specific so there's need for those in your DB but it's strange that signups is missing as well.

    Can you enable debug log in your wp-config.php by replacing define('WP_DEBUG', false); with this code:

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set( 'display_errors', 0 );

    Open your site now and this should create debug.log file in your wp-content folder that could tell us what is going on.
    Can you please save it as .txt file and attach it here so we can check it out.

    Best regards,
    Predrag

  • Alison

    Oooh not sure if that is attached or not? the contents of the file are as below:

    [17-May-2016 12:21:47 UTC] All-in-One Event Calendar: Cannot modify header information - headers already sent by (output started at /home/brocante/public_html/wp-config.php:1) @ /home/brocante/public_html/wp-content/plugins/all-in-one-event-calendar/lib/http/response/render/strategy/ical.php:19 #2
    [17-May-2016 12:23:17 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/brocante/public_html/wp-config.php:1) in /home/brocante/public_html/wp-includes/pluggable.php on line 1171
    [17-May-2016 12:24:17 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/brocante/public_html/wp-config.php:1) in /home/brocante/public_html/wp-includes/pluggable.php on line 1171
    [17-May-2016 12:26:17 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/brocante/public_html/wp-config.php:1) in /home/brocante/public_html/wp-includes/pluggable.php on line 1171
    [17-May-2016 12:29:48 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/brocante/public_html//wp-config.php:1) in /home/brocante/public_html/wp-includes/pluggable.php on line 1171

  • Predrag Dubajic

    Hi Alison,

    I think it would be best to perform plugin conflict test by disabling your plugins and see if the issues are still there after that.
    I noticed that F is inside sumome-smartbar-popup holder when inspecting your page, so you could start by disabling that one.
    Another would be All-in-One Event Calendar mentioned in the above debug log.
    And also try disabling Contact Form 7 as there's an error from this plugin showing in your console.

    Let us know if there are any improvements after that.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.