Multisite Required for Plugin?

I am considering installing the "set password" plugin on my site. I noticed the page says "multisite required"?

i'm not sure what that means, can you tell me if it will work on any theme?

-geraldine*