Multisite Sign up-Ultimate Facebook plugin

Hey Guys

I have a question regarding the way sign ups are handled via Facebook Connect using your Ultimate Facebook plugin.

On my multi-site network postfriendly.com I have received several sign ups this morning, one of which is from Facebook connect.

However, all members that registered are not assigned to a "site" (i am accepting user names only) except the member who signed up using Facebook connect.

The one who signed up using your plugin is attached to my main site in the network. Is this normal? I also did NOT receive an email alerting me of her joining my site.

I did get emails for everyone who did not sign up using Facebook. Can I receive notices for people signing up via Facebook connect?

Is it normal for users that sign up to my network to not be assigned to a site? even my main site? Thanks!

Mike

  • aecnu

    Greetings Mike!

    Thank you for the great questions and I must comment that I need a bit of clarification to answer all of these.

    But lets dig in and see what we got going on there.

    However, all members that registered are not assigned to a "site" (i am accepting user names only) except the member who signed up using Facebook connect.

    On this portion what do you mean assigned to a site?

    Did they get a sub site? Or join a sub site? Do you have sub sites?

    The one who signed up using your plugin is attached to my main site in the network. Is this normal?

    Yes this would be normal and they more then likely by default have subscriber privileges to the main site. Of course I say normal because you could be having the default set to something else, but normally a subscriber.

    I also did NOT receive an email alerting me of her joining my site.

    That is because you have chosen this form of signup which obviously completely bypasses the regular WordPress signup facility which indeed sends out the emails.

    Can I receive notices for people signing up via Facebook connect?

    This would be a possible feature request if it is possible, but due to the nature of the signup I think not.

    However, not being a coder I am indeed not sure.

    Therefore to be absolutely sure, I will see if I can get the lead developer in here with his invaluable insight into this plugin for his advice/advise for us and based on his answer will decide if to make this a feature request or not.

    Though this may take a bit longer then a normal ticket, I will try to get him in here asap.

    Cheers, Joe

  • Mike Price

    Hey Joe

    Thank you so much for the quick reply as I am starting to get more members signed up. I do have sub sites, each city is given a sub site on my network. Each member that signs up on my network is able to post on each network sub site using WP User Front end plugin though they are all "subscribers"

    The lady who signed up using Facebook connect got assigned to my main site on the network which you say is normal so thats great. however, everyone who used the normal sign up form didn't get assigned to any site (not even a subsite)

    I am guessing this is normal as they are only subscribers by default (user accounts) I am guessing the difference im seeing is the Facebook sign ups which seem to be listed on my main site on the network.

    For example, when im in admin for only my main site of the network and click on "Users" I see me obviously and then I see the lady that signed up using Facebook connect. Thats it. But if I go to "Network Admin" and click on "Users" I then see everyone else who signed up as well with no "sites" listed next to their username.

    Hope this clarifies. And yes I find it strange that it wasnt part of the original plugin to alert network admins of new signups. It seems this is an important thing to have.

  • aecnu

    Greetings Mike,

    Thank you for the additional input and clarifications.

    however, everyone who used the normal sign up form didn't get assigned to any site (not even a subsite)

    This has me worried.

    For example, when im in admin for only my main site of the network and click on "Users" I see me obviously and then I see the lady that signed up using Facebook connect. Thats it. But if I go to "Network Admin" and click on "Users" I then see everyone else who signed up as well with no "sites" listed next to their username.

    This is all intended use and perfectly normal to this point: I then see everyone else who signed up as well with no "sites" listed next to their username

    Can these user accounts access any site? Main site or sub site?

    You should run a test on this one.

    I am guessing this is normal as they are only subscribers by default (user accounts) I am guessing the difference im seeing is the Facebook sign ups which seem to be listed on my main site on the network.

    This would be because the Facebook app is configured to the main site, can you confirm this?

    Please advise on the results of the above suggested test of sub site users access.

    Looking forward to hearing from you in any event.

    Cheers, Joe

  • Mike Price

    Hey Joe

    Yes I did network activate Ultimate facebook but it does appear that I granted the extended permission on my main site and that is where I have the sign up with facebook button. So that makes sense then

    But i confirmed that new users were not being assigned a site. However, I think I figured this out. It might be due to the plugin "Wp User Frontend" as I set that up so that only Admins could gain access to dashboard and they would receive an error message. However, all those users could still post on the frontend as if they were authors.

    At any rate, all is well just thought it was interesting

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.