Multisite SSL not working on Marketpress site

Hi,

We have installed marketpress and hired a developer from your jobs section to write our custom gateway plugin. We have managed to get it all working perfect on tatestau.com however having problems with tri-alliance.com.au

Currently we’ve tested that the problem is related to SSL on one our sites. (the main blog site). ie

https://tri-alliance.com.au wont work, redirect loop

https://vic.tri-alliance.com.au which is a subsite works with https (few design errors but no redirect loops).

Our main site ssl does work an example of this is this image https://tri-alliance.com.au/wp-content/themes/trialliancemain/images/tri-header-logo.png

I have looked across the net, asked our gateway developer who’s quite savy with custom plugins and neither of us can figure out what is wrong here.

Does anyone have any advise to how we can fix this issue as its the major thing that’s stopping us move forward with Marketpress (as our gateway requires that its return link is https)

Thanks,

Billy

  • Patrick
    • Support Monkey

    Hi @ollie_allan

    It’s almost impossible to point you in any particular direction as you are working with a custom-designed gateway.

    The only suggestion i can make is to compare the scripts you have for the site that is working (tatestau.com) with those on the site that is not (tri-alliance.com.au).

    Perhaps someone else would like to chime in here?

  • Ollie
    • The Incredible Code Injector

    Hi Patrick,

    Thanks for your response. The reason why the gateway is not working is because it needs to visit a wordpress page which we have created to goto https://tri-alliance.com.au

    The gateway is working fine as the payment clears from the gateways end and works completely fine on other servers. This is something that is more an issue with server/ SSL & WordPress combined but because we need the SSL specifically for Marketpress it means we need to get ontop of this problem to start selling online.

    After researching, plenty of other people have stumbled across https problems with wordpresss so there must be some way to fix this.

    I have a feeling it may be server level but I know what the host will say. (we are on dedicated), they will just try and blame on wordpress and then we”ll be back where we started with hence why I’m putting it out there for some wordpress experts to hopefully chip into this post.

    Thanks,

  • Mason
    • DEV MAN’s Sidekick

    The easiest way to get things done is wi`th this plugin:

    http://wordpress.org/extend/plugins/wordpress-https/

    With the general settings for this plugin you’ll find a checkbox for “HTTPS front page” that you’ll want to enable.

    This plugin also allows you to mark specific pages as HTTPS and even helps with the debugging process if a page isn’t coming up as totally secure.

    Ths plugin should handle everything, but you can also manually modify this in your wp-config file by adding the following:

    define('WP_HOME', 'https://domain.com'); // no trailing slash
    define('WP_SITEURL', 'https:/domain.com'); // no trailing slash

    Let us know if that helps things for ya.

  • Ollie
    • The Incredible Code Injector

    Hi Mason,

    The plugin worked as advertised however it just forces the SSL (which will definitely be hand for later) however it still returns to a redirect loop the same as https://tri-alliance.com.au

    Its only being a problem on our main blog site, the sub sites are working fine with the same plugins and themes.

    btw the define wp_home & wp_siteurl had no effect at all.

    Thanks

  • Mason
    • DEV MAN’s Sidekick

    Hiya,

    If it’s looping still that means something somewhere is trying to redirect from https to http and then back to https. Somewhere it’s getting conflicting instructions on what to do here.

    You could try forcing https via the .htaccess file with this:

    RewriteEngine On
    RewriteCond %{HTTPS} !=on
    RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

    But that will force ALL links to be https. If that doesn’t do it then really you’ll need to contact your hosting provider or have someone take a look at your setup.

    Let us know how it goes. Thanks!

  • Timothy
    • Chief Pigeon

    Hello, hope you’re well.

    Just following up on some threads here and noted that we’ve not heard from you in a while.

    If you’re still looking for some assistance on this thread then please by all means reopen it or create a fresh thread for any new questions.

    Take care.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.