multisite subblog with no user? what does it mean?

was just going through my super admin "sites" backend and noticed a few subblogs with no user associated with them. what does that mean? most of my users are creating subblogs with similar names as their username.

for 1 subblog, i cannot find the username and i think i recall a user signing up a username at one point similar to that blug. anyway, the blog is still there, but no username associated with it.

in this case, i am imagining the user somehow canceled their username? but i have no idea how they would actually do that. (i know users can delete their blogs, however. see below)

for another subblog, i can find the username that most likely originally created the subblog. he's still a member, but for some reason his username isn't associated with his subblog.

in the 2nd case, is this user able to log in and go to their subblog dashboard still?

for both subblogs, i checked their dashboard and Users menu and found no users!

how does this happen?

i thought maybe the user deleted their blog, BUT i have tested and seen what happens when a user deletes their subblog. as expected, under the super admin Sites menu, the subblog shows up highlighted in red with a little "deleted" note, so i don't think that's what's going on.

  • Mason
    • DEV MAN’s Sidekick

    Hiya roberte,

    Are you using anti-splog or anything else that might cause a user's account to be deleted? That would be one possibility. Users can't delete their accounts (that I know of) so that is very odd.

    Anybody else ever encountered this and have some advice for roberte?

    Thanks!

  • Sue
    • Recruit

    Hi Roberte,

    Very occasionally I'll see a blog created with no username. Sometimes it will be due to issues with batch create files while other times it's probably due to someting interrupting the process while the blog is being created.

    Our standard approach with bugs is to see if we are able to replicate the problem and identify what part of the process might be involved. So in our case, if we needed to test, we would be testing the sign up form and the Blog & User creator. If we can't replicate then we'll keep an eye on it - as it might have just been a temporary issue or not.

    in the 2nd case, is this user able to log in and go to their subblog dashboard still?

    If the user isn't attached to the blog they won't be able to log in. So if the email address in Settings > General is the same as the email address of their username I would go ahead and add them to the blog as a user.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.