Multisite, subdomains media is not working, displays a grey box.

I am trying to create the subdomains for my website, and the images when uplaoded are grey boxes, can someone please help me.

thank you

  • Nithin
    • Support Wizard

    Hi Kerri,

    Do you notice the issue with every subsite, or the issue is specific to any one subsite? Could you please ensure the folder permissions for /wp-content/uploads, and /wp-content/uploads/sites are 755?

    Since support access to your website wasn’t enabled, it’s tough to say what exactly could be causing without checking the issue live.

    Could you please grant support staff access so that we could give a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know once you enable access so that we could get this sorted. Have a nice day. :slight_smile:

    Kind Regards,

    Nithin

  • Nebu John
    • Staff

    Hi Kerri,

    I had a look at your site and I could identify that your installation is using some old multisite settings, that were user prior to WordPress 3.5 release.

    The thing is that your upload path uses blog.dir as the path and that was removed from 3.5 and it’s probably what’s causing the issues.

    Can you check the guide from here for possible fixes for this issue:

    https://wordpress.org/support/article/multisite-network-administration/

    Feel free to get back to us here if you have any doubts or need any help further.

    Kind Regards,

    Nebu John

  • Nebu John
    • Staff

    Hi Kerri,

    Could you please try to replace the following rules from your .htaccess file here /home/kerri831/public_html/121831101.com/PDRalliance/

    RewriteEngine On
    RewriteBase /PDRalliance/
    RewriteRule ^index.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*.php)$ $2 [L]
    RewriteRule . index.php [L]

    with this

    RewriteEngine On
    RewriteBase /121831101.com/PDRalliance/
    RewriteRule ^index.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*.php)$ $2 [L]
    RewriteRule . index.php [L]

    These are the default ones from here

    https://wordpress.org/support/article/htaccess/#wordpress-3-5-and-up

    with a little change in line#2 (RewriteBase /121831101.com/PDRalliance/).

    Keep previous .htaccess file backed-up, just in case you have to revert it back!

    Looking forward to your results!

    Kind Regards,

    Nebu John

  • Nebu John
    • Staff

    Hi Kerri,

    I am sorry that the solution didn’t work for you.

    Could you provide us with cPanel and/or FTP access along with WP admin credentials so we can have a closer look at this?

    Note: Don’t leave your login details in this ticket.

    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: “Attn: Nebu John”

    – Site login URL

    – WordPress admin username

    – WordPress admin password

    – FTP credentials (host/username/password)

    – cPanel credentials (host/username/password)

    – Link back to this thread for reference

    – Any other relevant URLs

    Kind Regards,

    Nebu John

  • Nebu John
    • Staff

    Hello Kerri,

    Hope you are doing good today. :slight_smile:

    The WordPress credentials that you have shared is working but it seems that user capabilities are not defined. When logged in, I could only see/edit user profile, please find the following screenshot:

    I appreciate if you could change the user role to 'Administrator'. Please follow the below given steps to change the user role:

    Step1: Logging into your WordPress Dashboard as an administrator.

    Step 2: Click the Users link in the Navigation menu, then click the username that you want to change the role for.

    Step 3: Click the drop-down box located to the right of the Role option.

    Step 4: After selecting 'Administrator', click the Update User button.

    Please update here when you have changed the user role.

    Kind Regards,

    Nebu John

  • Nebu John
    • Staff

    Hello Kerri,

    Thank you for providing us with correct access. :slight_smile:

    Further, I made edits to ".htaccess" file with below-given code:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /121831101.com/PDRalliance/
    RewriteRule ^index.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*.php)$ $2 [L]
    RewriteRule . index.php [L]
    # END WordPress

    Media library is loading fine now. Please find the following screenshot:

    Feel free to get back to us here if you have any doubts or need any help further.

    Kind Regards,

    Nebu John

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.