Multisite subsite opening a directory window

My Amauter Radio multisite Website the sub sites when they open in a new window its a directory thats empty except for a directory cgi-bin
Index of /

Name Last modified Size Description
cgi-bin/ 2017-04-10 15:37 -

I disabled all plugin was the same.

I just moved from another server to this one and all is the same except the hostname.
one thing that did bother me was I do not have a dedicated IP on the other server I didn't either and everything worked with domain mapping and all.
I did check and the * A record is there for the catch all. IP is updated in domain mapping the mapped domains work.
I check the blogs.dir and its there 777
I recreated the network setup in wp-config.php and the htaccess file
web site of main domain is http://aresnyc.org/ and that loads
thanks
Mitch

  • Kasia Swiderska

    Hello HamRadioDude,

    This is subdomain multisite? if subdomains are not showing it means that Wildcards are not configured for your domain or on your server.
    You don't need dedicated IP to have working subdomains, but you need to check with your new hosting provider if server is correctly configured to handle wildcards.
    Let us know what will say provider.

    kind regards,
    Kasia

  • HamRadioDude

    It's a dedicated server and I'm Admin
    And I verified in nycares,org zone file there is an entry for wildcard with my IP
    * 14400 IN A xxx.xxx.xx.xx.

    Also noticed in the root of the website there is a directory called _wildcard_ if I remove it the sub domain will not load and I get

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator at webmaster@aresnyc.org to inform them of the time this error occurred, and the actions you performed just before this error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    Inside the _wildcard_ directory is a cgi-bin directory and a htaccess file
    Inside the htaccess file is

    # php -- BEGIN cPanel-generated handler, do not edit
    # Set the “ea-php56” package as the default “PHP” programming language.
    <IfModule mime_module>
    AddType application/x-httpd-ea-php56 .php .php5 .phtml
    </IfModule>
    # php -- END cPanel-generated handler, do not edit

    I did a search in Google and can't find why this Directory is there and if there is a setting to turn of sub domains or turn on. I believe it's automatically on just need to make the entry in DNS