Multisite Unable to Create Directory

Hi there,

I googled a lot and this is my last chance to get it.

I have a multisite installation in one of my subsites can not upload a slide. The wordpress generates the error “Error: unable to create the directory.” I tried everything. I changed the permissions and tried to reinstall wordpress. But the error persists.

I use multisite BitNami AWS and do not know what I do. Could anyone help me, please?

  • Rupok
    • Support Ninja

    Hi Alan, thanks for asking.

    Amazon servers don’t behave like just another linux server. They have higher security and more complex way to set up. So I’m not exactly sure what could be causing this. As you said “I changed the permissions and tried to reinstall wordpress”, can you please make sure how have all your directories having 755 or 750 permission and all files have 644 or 640 permission? The error clearly mentions that this is permission issue.

    I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:

    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Moreover, Can you send me message with SSH access credentials through our secure contact form here: https://premium.wpmudev.org/contact/ so we can check your current permissions and try to fix the issue?

    Subject: “Attn: Rupok”

    – SSH Username

    – SSH Password

    – SSH Host IP

    – Link back to this thread for reference

    – Any other relevant URLs

    Select “I have a different question” for your topic. This and the subject line ensure that it gets assigned to me.

    Please NOTE: You *must* create a full backup of your site before you share your SSH Credentials so we can always revert back to current state if anything goes wrong. Please let us know when you are done sending credentials. I’m looking forward to hear from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!

    Rupok

  • Rupok
    • Support Ninja

    Hi Alan,

    Chances are low that WP Defender may cause this, but you can confirm by simply deactivating the plugin. Can you please let us know if deactivating WP Defender resolves the issue for you?

    And please confirm when you send your credentials. We will be glad to investigate further if required.

    Have a nice day. Cheers!

    Rupok

  • Alan
    • Site Builder, Child of Zeus

    Hi,

    First, thanks Rupok.

    After 2 days I finally got ready. Really were the permissions.

    I managed to fix by adding the following code to wp-config.php

    Thank you very much.

    define( 'FS_METHOD', 'direct' );
    define( 'FS_CHMOD_DIR', ( 0755 & ~ umask() ) );
    define( 'FS_CHMOD_FILE', ( 0644 & ~ umask() ) );

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.