Multisite - Users cannot log in via /wp-admin/

Hi All,

I have a strange issue (one that is only happening on one particular server). I have installed Multisite on one of my domains to allow for local blogging for the community of our town. It is free so I am not using pro sites nor do I have any plugins activated at present.

I have tried twice with a clean install each time and fresh db and am getting the same issue. Basically if a user tries to go to /wp-admin on their sub domain, it redirects them to the main domain wp-admin therefore they cannot log in.

Example: http://jaxon.finedon.co.uk/wp-admin/

Redirects me to: http://finedon.co.uk/wp-login.php

This means users cannot log into their dashboards.

Even if they then login, and click on the "Visit Dashboard" link, it redirects back to main domain and give same message.

There are litterally no plugins active and I am using default twentyeleven theme.

wp-config:

# BEGIN WordPress
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# uploaded files
RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule . index.php [L]
# END WordPress
  • leejacksondev
    • Site Builder, Child of Zeus

    Here is wp-config:

    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     */
    define('WP_DEBUG', false);
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'finedon.co.uk' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    
    /* That's all, stop editing! Happy blogging. */
  • leejacksondev
    • Site Builder, Child of Zeus

    Hi,

    Thanks for message Phil. There are literally no plugins enabled at all. I did the install again fresh, with no plugins activated.

    To check the cookie thing, I opened the site in safari of which I have never used to access the domain before and the same issue occurred there too.

    Even in I go into privacy mode this URL:

    http://jaxon.finedon.co.uk/wp-admin/

    Goes to:

    http://finedon.co.uk/wp-login.php?redirect_to=http%3A%2F%2Ffinedon.co.uk%2Fwp-admin%2Fpost.php&reauth=1

    If you look at the code, the redirect does not include my sub domain:

    http%3A%2F%2Ffinedon.co.uk%2Fwp-admin%2Fpost.php&reauth=1

    Its very strange and does not happen on other servers I use.

    I've installed multisite before on 2 other servers with no issue and I am not doing anything different.

  • leejacksondev
    • Site Builder, Child of Zeus

    Linux Server. Its only on this domain and server its happening. (Finedon).

    The other ones work fine. One difference is this account is a reseller account on a shared server. The others are Dedicated VPS so it may be a setting I need to change?

  • leejacksondev
    • Site Builder, Child of Zeus

    This is what I do step by step.....

    Upload WordPress files, latest version.

    Add this to wp-config.php:

    define('WP_ALLOW_MULTISITE', true);

    I log in and go to setup network.

    I add this to wp-config.php:

    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'domain.co.uk' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    I add this to .htaccess:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]

    I create the blogs.dir in:

    /home/domain/public_html/wp-content/

    I log in again and then I select:

    Both sites and user accounts can be registered.

    Finally I....

    Open a new browser clear cache then I register for a new blog, but when I try and log into wp-admin it redirects me from sub domain to the main domain and gives me the same messages,

    Repeated these steps multiple times, running out of ideas.

  • leejacksondev
    • Site Builder, Child of Zeus

    To further add to the confusion, I cannot access the dashboard via the sub domain, but I can access say my profile area or say manage pages and add a post.

    http://support.finedon.co.uk/wp-admin/profile.php

    http://support.finedon.co.uk/wp-admin/edit.php?post_type=page

    It seems to be when trying to access the dashboard:

    http://support.finedon.co.uk/wp-admin/

    or

    http://support.finedon.co.uk/wp-admin/index.php

    How odd.

    :slight_frown:

  • leejacksondev
    • Site Builder, Child of Zeus

    Hi,

    Yes. * setup in cpanel going to /public_html which is location of installation. A setting that works on other servers.

    The sub domains work themselves. I am gonna switch host I think, I can only assume its a server setting that just doesnt like what I am trying to do.

    Cheers. Will post update if that works!

  • Mason
    • DEV MAN’s Sidekick

    Yeah, your hosting provider should be willing to support you in getting this sorted. You posted a very thorough walkthrough and I can't see where any step has been missed or configured incorrectly.

    If you don't get support from your provider, I'd switch. Let us know.

    Thanks!

  • leejacksondev
    • Site Builder, Child of Zeus

    Hi All,

    Moved host to one of the top recommended on a host review site. Did exactly the same install process and everything works with no issues. Must therefore be some server setting on my old provider.

    The main thing is I can now use Multisite!

    Hurrah!

    Cheers

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.