Multisite Wordpress Network Admin Pages Not Loading

My Multisite Wordpress stopped loading the Network pages of the admin section. Before this happened we did not update anything in the files, the site was accessible as of the last updates done on Friday last week.

I turned on wp_debug and received these errors when I tried to access the page:

Notice: bbp_setup_current_user was called incorrectly. The current user is being initialized without using $wp->init(). Please see Debugging in WordPress for more information. (This message was added in version 2.3.) in /home/content/94/11817394/html/wp-includes/functions.php on line 3060

Notice: bp_setup_current_user was called incorrectly. The current user is being initialized without using $wp->init(). Please see Debugging in WordPress for more information. (This message was added in version 1.7.) in /home/content/94/11817394/html/wp-includes/functions.php on line 3060

Notice: bp_is_member is deprecated since version 1.5! Use bp_is_user instead. in /home/content/94/11817394/html/wp-includes/functions.php on line 2919

Notice: bp_is_home is deprecated since version 1.5! Use bp_is_my_profile instead. in /home/content/94/11817394/html/wp-includes/functions.php on line 2919

Notice: Use of undefined constant mc_ps_parse - assumed 'mc_ps_parse' in /home/content/94/11817394/html/wp-content/plugins/parse-shortcodes/parse-shortcodes.php on line 16

I have attempted to disable plugins, reuploaded the twenty thirteen theme (some users said it was the theme on wordpress support forums), using different browsers, and even altered my wp-config file to include every define action I could find. I also attempted to disable the multi-site and when this was done I was able to access the plugins page again; however, it does not appear to have resolved anything so I have reenabled it.

My website loads correctly from what I can tell but I cannot access any Network pages including the Plugins section nor am I able to update plugins. Nothing in and under '/wp-admin/network/' loads -- it displays a white screen unless I have wp-debug enabled.

On safari I am able to use the Firebug extension to see this response:

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>500 Internal Server Error</title>
</head><body>
<h1>Internal Server Error</h1>
<p>The server encountered an internal error or
misconfiguration and was unable to complete
your request.</p>
<p>Please contact the server administrator
and inform them of the time the error occurred,
and the actions you performed just before this error.</p>
<p>More information about this error may be available
in the server error log.</p>
<hr>
<address>Apache Server at battleaxewarriors.com Port 80</address>
</body></html>

Any ideas on how to resolve this? The only reason I upgraded to Multi-Site was to use certain plugins that you guys provided so please forgive me that I do not know more about it. Thank you in advance for any help or advice.

  • Beth

    This is the original wp-config (****** are my sensitive data removed)

    <?php
    /**
    * The base configurations of the WordPress.
    *
    * This file has the following configurations: MySQL settings, Table Prefix,
    * Secret Keys, WordPress Language, and ABSPATH. You can find more information
    * by visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
    * wp-config.php} Codex page. You can get the MySQL settings from your web host.
    *
    * This file is used by the wp-config.php creation script during the
    * installation. You don't have to use the web site, you can just copy this file
    * to "wp-config.php" and fill in the values.
    *
    * @package WordPress
    */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', '*******');
    
    /** MySQL database username */
    define('DB_USER', '*******');
    
    /** MySQL database password */
    define('DB_PASSWORD', '*********');
    
    /** MySQL hostname */
    define('DB_HOST', '*******');
    
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    
    /**#@+
    * Authentication Unique Keys and Salts.
    *
    * Change these to different unique phrases!
    * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
    * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
    *
    * @since 2.6.0
    */
    define( 'AUTH_KEY',         '*********************' );
    define( 'SECURE_AUTH_KEY',  '*********************' );
    define( 'LOGGED_IN_KEY',    '*********************' );
    define( 'NONCE_KEY',        '*********************' );
    define( 'AUTH_SALT',        '*********************' );
    define( 'SECURE_AUTH_SALT', '*********************' );
    define( 'LOGGED_IN_SALT',   '*********************' );
    define( 'NONCE_SALT',       '*********************' );
    
    /**#@-*/
    
    /**
    * WordPress Database Table prefix.
    *
    * You can have multiple installations in one database if you give each a unique
    * prefix. Only numbers, letters, and underscores please!
    */
    $table_prefix  = 'bax_';
    
    /**
    * WordPress Localized Language, defaults to English.
    *
    * Change this to localize WordPress. A corresponding MO file for the chosen
    * language must be installed to wp-content/languages. For example, install
    * de_DE.mo to wp-content/languages and set WPLANG to 'de_DE' to enable German
    * language support.
    */
    define('WPLANG', '');
    
    /**
    * For developers: WordPress debugging mode.
    *
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    */
    define('WP_DEBUG', false);
    
    /** MULTI-SITE */
    define('WP_ALLOW_MULTISITE', true);
    
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    define('DOMAIN_CURRENT_SITE', 'battleaxewarriors.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    This is my 'new' wp-config that I made in hopes of fixing:

    <?php
    /**
     * Custom WordPress configurations on "wp-config.php" file.
     *
     * This file has the following configurations: MySQL settings, Table Prefix, Secret Keys, WordPress Language, ABSPATH and more.
     * For more information visit {@link http://codex.wordpress.org/Editing_wp-config.php Editing wp-config.php} Codex page.
     * Created using {@link http://generatewp.com/wp-config/ wp-config.php File Generator} on GenerateWP.com.
     *
     * @package WordPress
     * @generator GenerateWP.com
     */
    
    /* MySQL settings */
    define( 'DB_NAME',     '*******’' );
    define( 'DB_USER',     '*******’' );
    define( 'DB_PASSWORD', '*******’' );
    define( 'DB_HOST',     ‘*******’ );
    define( 'DB_CHARSET',  'utf8' );
    
    /* MySQL database table prefix. */
    $table_prefix = 'bax_';
    
    /* Authentication Unique Keys and Salts. */
    /* https://api.wordpress.org/secret-key/1.1/salt/ */
    define( 'AUTH_KEY',         '*********************' );
    define( 'SECURE_AUTH_KEY',  '*********************' );
    define( 'LOGGED_IN_KEY',    '*********************' );
    define( 'NONCE_KEY',        '*********************' );
    define( 'AUTH_SALT',        '*********************' );
    define( 'SECURE_AUTH_SALT', '*********************' );
    define( 'LOGGED_IN_SALT',   '*********************' );
    define( 'NONCE_SALT',       '*********************' );
    
    /* WordPress Localized Language. */
    define( 'WPLANG', 'en-US' );
    
    /* Custom WordPress URL. */
    define( 'WP_SITEURL',     'http://battleaxewarriors.com/' );
    define( 'WP_HOME',        'http://battleaxewarriors.com/' );
    define( 'WP_CONTENT_URL', '/wp-content' );
    define( 'UPLOADS',        '/wp-content/uploads' );
    define( 'WP_PLUGIN_URL',  '/wp-content/plugins' );
    
    /* Media Trash. */
    define( 'MEDIA_TRASH', true );
    /* Trash Days. */
    define( 'EMPTY_TRASH_DAYS', '15' );
    
    /* Multisite. */
    define( 'WP_ALLOW_MULTISITE', true );
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    define('DOMAIN_CURRENT_SITE', 'battleaxewarriors.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    
    /* WordPress debug mode for developers. */
    define( 'WP_DEBUG',         false );
    define( 'WP_DEBUG_LOG',     true );
    define( 'WP_DEBUG_DISPLAY', false );
    define( 'SCRIPT_DEBUG',     false );
    define( 'SAVEQUERIES',      false );
    
    /* PHP Memory */
    define( 'WP_MEMORY_LIMIT', '64M' );
    define( 'WP_MAX_MEMORY_LIMIT', '256M' );
    
    /* WordPress Cache */
    define( 'WP_CACHE', true );
    
    /* Compression */
    define( 'COMPRESS_CSS',        false );
    define( 'COMPRESS_SCRIPTS',    false );
    define( 'CONCATENATE_SCRIPTS', false );
    define( 'ENFORCE_GZIP',        false );
    
    /* FTP */
    define( 'FTP_USER', '*******' );
    define( 'FTP_PASS', '*******' );
    define( 'FTP_HOST', 'battleaxewarriors.com' );
    define( 'FTP_SSL', false );
    
    /* Updates */
    define( 'WP_AUTO_UPDATE_CORE', true );
    define( 'DISALLOW_FILE_MODS', false );
    define( 'DISALLOW_FILE_EDIT', false );
    
    /* Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /* Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    Here is .htaccess file

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    </IfModule>
    
    # END WordPress
  • Patrick

    Hi again @Beth

    Phew, that's a lot of extra stuff in wp-config!

    Let's start by going back to the basics. Please replace the contents of wp-config with this:

    define('WP_DEBUG', false);
    define( 'WP_ALLOW_MULTISITE', true );
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    define('DOMAIN_CURRENT_SITE', 'battleaxewarriors.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    And replace contents of .htaccess with this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    </IfModule>
    # END WordPress
  • Beth

    I replaced the htacess file with the above in full and removed all lines except for the calls to the database, the table prefix, and the auth_key lines (as well as the absolute path calls at the end) so my wp-config now looks like:

    define('WP_DEBUG', false);
    define( 'WP_ALLOW_MULTISITE', true );
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    define('DOMAIN_CURRENT_SITE', 'battleaxewarriors.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    
    /* Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /* Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    I am still receiving a blank page on the Network admin -- I tried accessing via Firefox, Chrome, and Safari all with cleared cookies and cache.

    Firebug on Safari is still showing a 500 error:

    GET http://battleaxewarriors.com/wp-admin/network/safari-extension://com.slicefactory.firebug-M6DQ5JZ52E/93a94bc0/chrome/firebug-lite-beta.js
    500 Internal Server Error
    304ms
    ResponseHeaders
    Date	Thu, 12 Dec 2013 17:16:12 GMT
    Server	Apache
    Connection	close
    Content-Length	579
    Content-Type	text/html; charset=iso-8859-1
    RequestHeaders
    X-Requested-With	XMLHttpRequest
    <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>500 Internal Server Error</title>
    </head><body>
    <h1>Internal Server Error</h1>
    <p>The server encountered an internal error or
    misconfiguration and was unable to complete
    your request.</p>
    <p>Please contact the server administrator
     and inform them of the time the error occurred,
     and the actions you performed just before this error.</p>
    <p>More information about this error may be available
    in the server error log.</p>
    <hr>
    <address>Apache Server at battleaxewarriors.com Port 80</address>
    </body></html>

    Firebug on Firefox shows this error:
    The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol.

    When I originally set up the Network I did disable ALL plugins -- should I try to do that again?

  • Beth

    I set up error logs on GoDaddy's hosting as well and this is what came up today when I tried to access the network pages:

    [Thu Dec 12 10:03:22 2013] [11817394] [fcgid:warn] (104)Connection reset by peer: [client 23.125.72.161:55770] mod_fcgid: error reading data from FastCGI server, referer http://battleaxewarriors.com/wp-admin/my-sites.php
    [Thu Dec 12 10:03:22 2013] [11817394] [core:error] [client 23.125.72.161:55770] End of script output before headers: index.php, referer http://battleaxewarriors.com/wp-admin/my-sites.php
    [Thu Dec 12 10:07:06 2013] [11817394] [core:error] [client 23.125.72.161:55871] AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer http://battleaxewarriors.com/wp-admin/network/update-core.php
    [Thu Dec 12 10:16:12 2013] [11817394] [core:error] [client 23.125.72.161:56368] AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer http://battleaxewarriors.com/wp-admin/network/
    [Thu Dec 12 10:30:08 2013] [11817394] [fcgid:warn] (70007)The timeout specified has expired: [client 67.193.59.214:37461] mod_fcgid: ap_pass_brigade failed in handle_request_ipc function

    I am IP 23.125.72.161 so the last error log may have been a user on the website.

  • Beth

    Progress update: (I'm sorry I have to continue working on this and trying things even though I'm hoping for advice from someone wiser, thank you again Patrick).

    I see wordpress has the 3.8 upgrade so I went ahead and renamed the plugins directory and this restored access to the Network Dashboard -- I upgraded to 3.8 and I am going through the plugins one at a time and trying to find the culprit.

  • Beth

    I haven't found any plugins that are causing the issue specifically but Press Permit even existing in the plugins folder (non-active) seems to cause the system to be unhappy and the Network pages stop responding.

    I am currently experiencing TONS of connection resets and timeouts. I'm not really sure what is causing the problem but I have opened a support ticket with GoDaddy.

    If anyone has any advice on how to figure out where the unhappiness is coming from I am all ears. I did not have this problem before the Multi-Site upgrade and I have not altered the site very much since (save for installing a few WPMU plugins, most of which I haven't activated as the problems started when I did the Multisite upgrade to use those plugins).

    Better WP Security has a really delayed activation and deactivation time so I'm not sure if that is because it is large or because it is running into warnings.

    Should I turn debug back on?

    Thank you again

  • Patrick

    Hi again @Beth

    Wow, you've had a busy day!

    Glad you regained access to your network admin. Renaming the plugins folder to deactivate all plugins was the right thing to do.

    Better WP Security & Press Permit are powerhouse plugins that do modify core WordPress functionality. If you are using those, be sure you have no other plugins active that modify user roles, or site security. Also, go over the settings with a fine-tooth comb to be sure you don't lock yourself out of admin areas.

    Also, please keep us informed of any feedback you get from GoDaddy.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.