My website is producing PHP errors

My website is now producing the following errors...And I am not sure what caused them or now to fix them. Any help would be appreciated, and I need a lot of it lately!

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/bdubdesi/public_html/wp-includes/plugin.php:525) in /home/bdubdesi/public_html/wp-content/plugins/1pro-sites/pro-sites-files/lib/ProSites/Helper/Session.php on line 29

Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'custom_oembed_provider' not found or invalid function name in /home/bdubdesi/public_html/wp-includes/plugin.php on line 525

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/bdubdesi/public_html/wp-includes/plugin.php:525) in /home/bdubdesi/public_html/wp-content/plugins/1pro-sites/pro-sites-files/lib/ProSites/Helper/Session.php on line 29
  • Adam Czajczyk

    Hello Blake,

    I hope you're well today and thank you for your question!

    These errors are actually warnings so they are not critical and shouldn't affect site's performance. "Warnings" and "notices" are more like informational messages to developers rather than "bug indications".

    I noticed however that the Pro Site plugin on your site is located in a non-standard folder. My suggestions would be:

    1. Move Pro Sites to a "standard" folder:
    - disable Pro Sites plugin
    - access the site via FTP
    - go to /wp-content/plugins/ folder
    - rename "1pro-sites" folder to "pro-sites"
    - enable plugin again

    2. Disable WordPress debugging
    - access the site via FTP
    - edit "wp-config.php" file
    - if there's a

    define('WP_DEBUG',true);

    line inside either remove it or change to

    define('WP_DEBUG',false);

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.