My appointments+ calendar is not showing to non-registered users

Hi,

My appointments+ page does not show anything unless I am logged in to my Wordpress site.

I have set a page, with all the short codes at the following address:
http://www.doctorcall.co.uk/aqa-well-person-appointments/

However, you can only select a service provider and appointment when I am logged in. I have selected the option to 'Login required: no' in the options.

Please can you help?

Also, the [app_my_appointments] shortcode doesn't show the client name. Is there a way to make this happen?

Thanks