My Appointments for Plugin Appointments

Hello,
I have a couple of problems with My Appointments :

[app_my_appointments]

1. My confirmed appointments are not showing up on browser Google Chrome at all. I am logged on as the Client. It shows up for Firefox, IE and Safari.

2. My pending appointments are not showing up at all, no matter what browser I use, again I'm logged on as the Client. According to the "shortcode" for it, I should be able to see it.

status: Which status(es) will be included. Possible values: paid, confirmed, completed, pending, removed. Default: "paid, confirmed"

3. My confirmed appointments are only showing up at the PC that I made the appointment at, again I'm logged on as the Client. If I go to another PC and log on as that Client, I see no appointments.

Thanks!

  • JamesStewart312

    Hi,
    Can you tell me if I'm getting this correct:

    1. The client's appointments will only show up in the browser that they created it on, if they are not logged on, even if they use another browser on the same PC, with required login=no set? (saved on browser's cookies)

    2. If the client is already logged on to wordpress before they access make-an-appointment page, and required login=no is set, their appointments are still only saved to cookies for that browser, eventhough they are logged on?

    3. We have to set login=yes and force them to login from Appointments front end than their appointments are shown across browsers and PCs?

    Thanks!

  • Hakan

    Hi,

    No, not like that.

    Even if you set login required=No, but user is indeed logged in, appointment data is saved in a cookie and at the same time it is assigned to that user on the database. You can see this in the appointment record on the admin side.

    When client accesses the website using another PC and logs in, A+ combines database records for that user plus his cookie records, if there are any.

    So in this case, he should be seeing his appointments from the other PC too.

    As a result, to view the appointments cross browser or using another PC, login required setting=yes is not required, but login itself is required.

    The above screenshots were taken when login required was set as No, but I was logged in.

    Please note that as default pending appointments are not shown in the front end list. You need to change the shortcode if you want it so:

    [my_appointments status="pending,paid,confirmed"]

    This may explain why you don't see the (pending) appointment on the list.

    Cheers,
    Hakan

  • JamesStewart312

    Hi Hakan,

    I have this coded for my page :

    [app_my_appointments status="paid,confirmed,completed,pending,removed"]

    This is what's happening with me (I cleared all my cache from my browsers as well as removed all appointments, in other words I started from scratch)

    I'm logged on as User, I make an appointment (confirmed), pretend to pay, and then cancel the payment, when I get back to my site, under
    My Appointments it shows up my appointment as pending. So far as good.

    I double check under Pending Appointments on the dashboard, and I can see my appointment under client as my User as pending. So far so good.

    I then go to another PC, log on as the same User above and go to Make-an-Appointment. Nothing shows up for "My Appointments"
    I then go and make another appointment (confirm it), pretend to pay and then cancel the payment, when I get back to my site, under
    My Appointments it shows the newly pending appointment and finally my other pending appointment that I made at another PC.

    I then go back to the original PC, logged on as the same User, and under My Appointments it just shows the first appointment I made, double check on the dashboard and I see 2 appointments for that user.

    So in other words, my other appointments doesn;t show up at a different PC or browser till I make another appointment there.

    Thanks!