My backend told me that there is v3.4.3 available… …but

My backend told me that there is v3.4.3 available…
…but it's not!