My Checkout is directing me to a 404 page. Please help!

The checkout link for my store is not adding "/index.php/" to the link and is causing a 404 error. All the other links that I have on Marketpress are working fine until you start the checkout process and that's where the links are not correct.

The link currently is "http://proav.celabs.net/buy-online/shopping-cart/".

Where it should be "http://proav.celabs.net/index.php/buy-online/shopping-cart/" which actually works and continues the checkout process.

I have my permalink settings correctly set to "http://proav.celabs.net/index.php/sample-post/" as indicated in your walkthrough videos.

Could you please tell me what I need to do in order to straighten this issue out?

  • Jack Kitterhing
    • Code Norris

    Hi there @Tony

    I hope you are well today and thank you for question, ideally your permalinks shouldn't have /index.php within them as this can cause issues.

    Could you post a screenshot of your permalinks settings and also paste your .htaccess file here please? :slight_smile:

    Thank you!

    Kind Regards
    Jack.

  • emay
    • Site Builder, Child of Zeus

    Hi, Jack. Thanks for responding so quickly. Attached is the screen shot of my permalink settings. As for the .htaccess file, it looks as though I do not have one. I am on a Windows server if that has anything to do with it.

  • emay
    • Site Builder, Child of Zeus

    I do, however, have a web.config file. I think this is what IIS uses. The following code that is in the file is...

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
    <system.web>
    <identity impersonate="false" />
    </system.web>
    </configuration>

  • Jack Kitterhing
    • Code Norris

    Hi there Tony,

    I hope you are well today and thank you for the additional information, that explains not having a .htaccess file :slight_smile:

    Here is the official link on WordPress to installing pretty permalinks on an IIS Microsoft web server http://codex.wordpress.org/Installing_on_Microsoft#Step_5._Enable_clean_URLs_.28Pretty_Permalinks.29

    It looks like on your permalinks, the index.php could be taken out manually, by choosing custom structure and just leaving the post name section, which then may work, I think it's worth trying, but before you do, I'd recommend creating a backup of your website before trying :slight_smile:

    Thank you!

    Kind Regards
    Jack.

  • emay
    • Site Builder, Child of Zeus

    Hi Jack. Thank you for the guidance. Unfortuantely, it doesn't seem to be working for my set up. Should I go ahead and request a refund for this product or are there any other options?

    Can we set up Marketpress in order to include "index.php" in the link structure?

  • emay
    • Site Builder, Child of Zeus

    Woohoo! I did finally get it to go through.

    However, once I click "Checkout now" to continue onto the next step, which is shipping I am getting a "This page is unavailable".

    On the back end for my shipping settings in Marketpress I have placed all my username and PW as well as my developer kit access key and shipper number in the UPS settings.

    Any idea what could be going wrong?

  • emay
    • Site Builder, Child of Zeus

    Jack,

    I have located the problem being no SSL certificate. We are now currently up and running and I have a working eCommerce section on my site using Marketpress. Thank you for the assistance and don't be surprised if I have more questions down the line.

    Thank you!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.