My Custom Sidebar Setups Have ALL Been Deleted!

I had an issue with a plugin and was told to disable all plugins to find the problem plugin.

After re-activating all of my plugins, all of my custom sidebars were gone - deleted!!!

That's ridiculous.

How do I get my custom sidebar setups back?!

To be clear of of my widgets and etc, that was setup within each custom sidebar is gone.

  • faydra_deon
    • WordPress Warrior

    Hello, @Melodye:

    When you go to Appearance > Widgets, do you see any information for Inactive Widgets that are separated by groups of inactive widgets, which would represent each of the custom sidebars you created?

    Check and see if there's any information in the database that you can link back up to.

    If not, it's possible that you will have to do the work all over again.

    A plugin I use when doing the "deactivate all plugins to see if they are the problem" scenario is Widget Importer & Exporter.

    It'll allow you to make a backup of your widgets and their sidebar setups, in case you need to move or restore what you had before you lost them all.

    Faydra...

  • Kasia Swiderska
    • Support nomad

    Hello Melodye,

    I sorry to hear that your sidebars are gone.

    I've tried to replicate this issue but simple deactivation didn't erase sidebars I've created before.

    Are you sure that between deactivating and activating plugins there wasn't anything else going on your site?
    Do you have any backup of your site that you could restore?

    Information about sidebars and its content is kept in database in table wp_options. So with deactivation it should be still there.

    Would you mind allowing support access so we can have a closer look at this?
    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    kind regards,
    Kasia

  • jdcogmon
    • Flash Drive

    custom sidebar crashed while uploading
    [26-Nov-2016 05:22:51 UTC] PHP Fatal error: Cannot make static method TheLib::pointer() non static in class TheLib_Html in /home/yemaysis/public_html/wp-content/plugins/custom-sidebars/inc/external/wpmu-lib/inc/class-thelib-html.php on line 1624
    i had to delete the folder to get your dashboard to recognize that it was no longer there. I zipped the contents before i deleted it, so how can i get all of my settings back? which folder do i replace with old settings?

  • Nithin
    • Support Wizard

    Hi jdcogmon,

    Deleting the folder/files from your server directory wouldn't delete your settings, as the settings are saved in your database. If the settings are deleted from your database, then I'm afraid, there isn't any way to get that back, unless you have a backup. If you are sure, that you haven't deleted any settings from the database, then you could check whether any other plugin is causing a conflict, by quickly running a plugin conflict test, as illustrated in getting support manual (flowchart):
    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    If you still have issues, would recommend you to create a new thread, so that one of the support staff could give this a closer look, and get this sorted asap:
    https://premium.wpmudev.org/forums/#question

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.