My emails were sending. Now they are not. When testing

My emails were sending. Now they are not.

When testing I tried the lost password and got this.

The e-mail could not be sent.

Possible reason: your host may have disabled the mail() function…

I tried searching the WPMUDev search for email.

That was a mistake. :slight_smile:

So. Bing pulled up this plug in and a few recommendations.

http://wordpress.org/extend/plugins/wp-mail-smtp/

What is the best, most dependable way to set up network emails?

  • Jack Kitterhing
    • Code Norris

    Hi there @richardewallacejr

    I hope you are well today.

    Very strange that your install has stopped sending mail, have you checked with your host to make sure they aren’t having problems with the mail function? Which version of PHP are you using?

    With regards to the SMTP setup, what are you using? Gmail SMTP or your own SMTP server? You may find this of some help here http://www.wpbeginner.com/plugins/how-to-send-email-in-wordpress-using-the-gmail-smtp-server/

    Thank you for being a WPMU DEV member and have a great weekend!

    Kind Regards

    Jack.

  • Richard
    • The Incredible Code Injector

    It is strange. As I research it seems pretty common.

    Also, it works fine on my other networks with he same server.

    I did send a note to the support for my server.

    Still no work from them.

    PHP version 5.3.2

    I already have a lot of interest in what I am doing.

    Need the best way to email without getting shut down.

    I will read the article.

    Need the best way to send without being blocked.

    All the best

    Richard

  • Shawn
    • The Crimson Coder

    Any chance you changed your email address for your blog account, or the email account at “/wp-admin/network/settings.php” (WPMS) or “/wp-admin/options-general.php” (WP) is not associated with the hosted domain? These are the most common problems when email stops sending within WP.

  • Shawn
    • The Crimson Coder

    Oh – and if you changed it but it’s still associated with the domain, your host may have disabled the ability to send from a non-existing email address (noreply@ for example) – you’ll need to make sure that the email address is an *account* within your hosting settings, not simply an alias or catch-all.

  • Richard
    • The Incredible Code Injector

    I did so much stuff during the install process and trying to fix other bus that I cold not even keep up with my normal logging. I normally log step by step so I can retrace my issues. Not the case lately. Too far behind and things changing too fast.

    I did decide to build my sales teams with separate sub domains and databases for each BuddyPress install. I may take a little more space, but if there is an issue I won’t have to rebuild all the sties again. I just feel I’ve been trying to twist the old rubix cube too far outside the box. Trying to make the SPMS and multi Network do more then it was intended to.

    Need to keep it simple.

    Thanks for the reply Shaen

    I already reinstalled.

    Time to get setting up.

    All the best

    Richard

  • Richard
    • The Incredible Code Injector

    This may be a noob mistake again, but it may also be something that can be corrected.

    I have spent all this time installing and removing plug ins. Installing and re-installing my Wp and WPms to figure this email issue out.

    I did finally figure out that you can not activate the HTML email template plug in without any html in it or your current mail will stop working.

    The error message says that my host may have disabled my mail().

    Maybe there should be a note that pops up when activating it that says it needs html in it or it will cause this issue.Maybe it can come with a shortcode that pulls the site title in for starters.

    I’m not upset. If I had a better process for finding errors it would not have taken me so long to find it.

    Also, the WPMU DEV dash automatically activates the plug ins so I did not get to adding html until after finding the email issue.

    All the best

    Richard

  • Jack Kitterhing
    • Code Norris

    Hi there @richard

    I hope you are well today, first of all I’d like to apologize about the extreme delay here, I missed your previous reply.

    Thank you very much for the feedback :slight_smile: I will be sure to pass thing along, as I can easily see how this could happen.

    Thank you for being a WPMU DEV member and again sorry about the delay.

    Kind Regards

    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.