My Friday appointments should be 2.5 hours not 30 min

Hi, I am still experiencing a problem with Appointments+. For some reason, if you look at May 19th, my Friday appointments show up in 30 min blocks in the AM. My appointments are 2.5 hours long, so it should only be 10:30 am and 3:00 pm. But I'm seeing 10:30, 11:00, 11;30, and then 3:00pm.
This only happening with Fridays, basically, for the last 2 months, this plugin has had SO many glitches, it's one thing after another :slight_frown: it has a mind of its own)

  • Majid

    Hey Rsatya,

    I noticed that your fridays working/break hours are kinda different than the rest of the week, as you can see there is a 4hours gap between the day start (10.30am) and the first break (2.30pm). but since your sessions are 180mins (3hours) this leaves one hour gap between 1.30pm-2.30pm. which is neither work or break.

    In order to fix the issue you must always set 3hours between the day start and the first break. this can be achieved by starting friday's break at 1.30pm.

    Then for example you will notice that the 19th have only one appointment available which is the 11.30am, the 3.00pm session won't appear since it's already reserved.

    Let me know if this works for you.

    Thanks,
    Majid

  • rsatya

    Hi Mike,

    Sorry, this seems like jibberish to me at the moment.
    The thing is, I never changed the settings, my appointments were always 10:30am and 2:00pm every day of the week (except Wednesdays which I have off).
    As for Fridays, they were 10:30 and 3:00pm. My appointments are 2.5 hours long, with a 30 minute break. Do you mind helping me set this up in the settings? Because as far as I can see nothing has been changed but this error is occurring for me.

    Thanks,

  • Majid

    Hi Rsatya,

    Your Friday sessions before the first break are set to 4 hours instead of just 3. for example
    Monday is 10:30AM -> 1:30PM that's 3 hours which is fine because in the settings it's set to 180 minutes, but for Friday it's start at 10:30AM -> 2:30PM that's 4 hours and that is causing the plugin to break.

    To fix the issue you will have to make the break one hour earlier. and the gap between the start of the day and the first break should be 3 hours (that's because the session length is 180min)

    And please let me know if I'm understanding you wrong.
    Regarding the email notifications issue, I'm taking a look at it too.

    Cheers,
    Majid

  • rsatya

    Hi Majid,
    As I mentioned previously, I never changed any of these settings and the Friday just started acting up a couple weeks ago out of nowhere so I am hesitant to make these changes myself, can you please help me by doing it for me? I get really anxious toggling those settings.

    And yes, thank you. I usually get a Paypal notification and a "new appointment" email, I dont get the email anymore, and also the appointment doesnt show up in my google calendar like it used to....

    Support access is still granted by the way :slight_smile: thanks.

  • rsatya

    Hi there

    I have waited over 10 days with no response, and now I am seeing yet another glitch with my calendar.

    If you look at June 8, 10, 11 etc, you will see only my AM appointments are showing up.

    I really dont know what to do or what is causing so many issues with this plugin. It has been acting up since early March and as soon as one problem is solved another appears to replace it.
    Can someone please help me look into these issues as well as overall? I am not sure if something is simply corrupt within the system that is causing these never ending glitches.

  • Majid

    Hi again Rsatya,

    I did a test on my site with your same settings except I used Appointments+. The schedules were on time and I could see 2 appointment per day. But then I tried with the same settings again with Appointments Lite which is the plugin you are using at the moment and I could see the issue. So I suggest that you will be upgrading to App+.

    I can do that for you if you provide me with FTP access.

    Please send in:

    Subject: "Attn: Majid Hamdani"

    - Mark to my attention, the subject line should contain only: ATTN: Majid Hamdani
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - login URL and admin account login credentials (may be a temporary admin account) data
    - Include FTP log-in details (hostname, username & password)
    - Include hosting control panel access details (login address, username & password)
    -- cPanel's usually the control panel used for this, but your provider may use something else; I'll need this for accessing your site's database, preferably via phpMyAdmin
    - Include any relevant URLs for your site

    Please use our contact form here http://premium.wpmudev.org/contact/.

    Select "I have a different question" from the drop-down list.

    Regards,
    Majid

  • rsatya

    Hi Majid,

    I hope this finds you well! I am writing you because I am YET AGAIN having issues with the Appointments+.. it has downgraded to Appointments Lite again I believe? I am not able to see my 2pm appointments, only my 11am appointments - which is obviously really bad for business.

    I am wondering if you can please help me get back on track and if we have a way to resolve this issue once and for all as it is the 4/5th time that this has happened? It has been acting up since March and about once a month the Appointments section of my website (which is essentially the whole point) has a giant malfunction.

    I tried to reinstall it and it wont let me... I'm not sure if you remember exactly from before? If you need credentials please let me know, I've enabled support access, and can provide credentials for cPanel etc.

    Thanks,
    Rojin

  • Nastia

    Hello Rojin,

    Hope you're doing well!

    I can confirm that the Appointments plugin is running a lite version now,

    To install the Pro version please download the plugin from the Appointments+ page, unzip the content. Then access your site's files using FTP , navigate to /wp-content/plugins/ and replace the appointments folder.

    If you need assistance, please send your credentials to us so we could replace the version for you. You can send credentials by using our secure contact form
    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Subject: “Attn: Nastia”
    - WordPress admin username
    - WordPress admin password
    - Login URL
    - FTP credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant URLs

    Once the version is replaced, it will enable the plugin's add-ons, that should fix the issue with time slots.

    Looking forward to your reply!

    Kind regards,
    Nastia