My home page is protected and I don't want this. I don't

My home page is protected and I don't want this. I don't have the checkbox to over ride this rule.

how to fix this and what am I doing wrong?

thanks,