My main site is JosephCavallini.com. I have installed whmcs

My main site is JosephCavallini.com. I have installed whmcs mu provisioning and domain mapping plugins. Currently I am able to activate the wpmu site comsivedemo.com from whmcs using the whmcs mu provisioning plugin. I have not been making any progress on the domain mapping. There are two issues I have noticed. The only thing I want my customers to be able to do is have one top level domain per wordpress account. They won't need to combine any additional domains for any other reason. (btw I am running a dedicated server, have dedicated ip address, sunrise installed, planning to sell wordpress ms to customers via whmcs)

1)Under super admin->all sites>/comsivedemo I am getting some setting messed up by default. They work after I manually edit the setting, but I don't want to do this for every site. See picture.
2)I don't understand what else I need to do to get the customer to map their one top level domain. can this all be done within wordpress?

  • PC

    Hello @propopulus

    Greetings and thanks for posting on the forums.

    I see that site link is all messed up. It should be xyz.yourmainsite.com for any subdomain site created on your network.

    It tells me that there is some issue with the settings of your network or your site.

    Can you please try the below

    1: Enable registrations on your site
    2: Signup for a subsite using the default WordPress signup process and see what link is created once the site is registered.

    It will help us see if the subsite creation on the network is working fine or not.

    Once you have tested that, please ensure that you have followed all the steps on the usage page of WHMCS MU Provisioning plugin. They are here : https://premium.wpmudev.org/project/whmcs-multisite-provisioning/#usage

    Please advise so that we can get this sorted out asap.

    Cheers, PC

  • propopulus

    Hello,

    I just enabled registration on the site, and I tried adding 2 new sites.

    This is as far as I got, it never sent me the activation email, it also said the website would be in the format josephcavallini.com/comsivedemo2 while I was signing up.
    Congratulations! Your new site, comsivedemo2, is almost ready.

    But, before you can start using your site, you must activate it.

    Check your inbox at josephcavallini@yahoo.com and click the link given.

    If you do not activate your site within two days, you will have to sign up again.

    Still waiting for your email?

    If you haven’t received your email yet, there are a number of things you can do:

    Wait a little longer. Sometimes delivery of email can be delayed by processes outside of our control.


    Check the junk or spam folder of your email client. Sometime emails wind up there by mistake.

    •Have you entered your email correctly? You have entered josephcavallini@yahoo.com, if it’s incorrect, you will not receive your email.

  • propopulus

    Hello,

    It turns out that another plugin was causing emails not to be sent out. This has been resolved.

    I keep deleting the test site (comsivedemo.com) and activating it through the whmcs. When I activated it through the regular wordpress signup everything worked perfectly. (Please note though, that I did not set up a top level domain through the wordpress. So I could set up josephcavallini.com/comsivedemo not comsivedemo.com)

    I think MU provisioning is working fine, I think it is the domain mapping that is an issue.

    After re-activating comsivedemo.com through the whmcs again, it sent me an email telling me:

    Your new Joseph Cavallini site has been successfully set up at:
    http://josephcavallini.comcomsivedemo/

    *************Login info Edited for Security reasons*************

    For some reason it is not getting a slash in there.

  • PC

    Hello @propopulus

    Thanks for posting back and providing the detailed info.

    Is it a subdomain or subdirectory multisite ?

    Did you have a look at the readme file in the plugin files. I have included that here.

    == <strong>If your Wordpress Install Offers Domain Mapping as well as subdomain/subdirectroy installs</strong> ==
    Create a Product =
    1. Create a Product Group to Hold the new products
    2. In WHMCS admin go to Setup | Product/Services and Add New Product
    3. Create a Product and Set the Product Type to Hosting Account.
    4. Set the Product Group to the one created above.
    5. Give the Product a meaningful name
    6. On the Details Tab TICK Require domain. Other fields as you prefer
    7. On the Modules Settings Tab Select whmcs_multisite as the Module name
    8. Select the Server Group defined above.
    9. Set a default blog title. This can be edited by the user in Wordpress after blog is created ("My New Blog").
    10. Set a default Blog Domain. If you're not using Custom fields(see below) this is the default domain name that will be used with numbers appended.
    11. UNTICK the two custom field names.
    12. Set the default role of the User that may be created for this product. Usually "administrator".
    13. Set the Web Space Quota or leave blank for Wordpress default value.
    14. Set the Radio buttons for when the product setup will occur.
    15. Do not create custom fields.
    16. If you want to offer subdomain/subdirectory installs as well as Domain Mapping =
    17. On the Other Tab fill in the Subdomains Option with your sites primary domain ('.mysite.com") Note the leading dot.
    18. Rest of the Product fields are Admin's choice.
    
    == Known Issues ==
    1. If a user does not already exist on Wordpress as determined by matching the WHMCS Clients email
    with the Wordpress users email, a new user will be created using the WHMCS Client's email address and
    the portion before the '@' as the users name. If you are Accepting Orders in Admin before creation you
    can change the default username there. Once the username is created it cannot be changed. 
    
    2. If the WHMCS clients email address already exists as a user in Wordpress the Wordpress user account
    will override what you may put in WHMCS. Wordpress user names can not be changed and this is enforced in WHMCS.
    
    3. WHMCS generates random passwords when creating a service. If a new Wordpress user is
    created as a result this random password is the password for the new user. If the user already exists
    in Wordpress WHMCS still generates a random password but it does NOT change the Wordpress password.
    WHMCS can change the password on Wordpress but Wordpress password changes will not be feed back to WHMCS.
    
    4. Each WHMCS service creates different random passwords so they will not match if a Client has more than one
    service at the same Wordpress site.

    Also, before you check the settings in WHMCS, can you please ensure that Domain mapping is working fine ?

    The best way to do it is, create a site via backend, and map a domain to it using domain mapping to see if the mapping is working fine or not.

    Once that is tested, disable domain mapping and just work with WHMCS MU provisioning using the above info and see if there is anything you have done differently than the directions above.

    Please advise if that helps.

    Cheers
    PC

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.