My map in post shows the tip of Manhattan and then my map

I am using Google Maps Pro and have a single map on a post with a KML overlay. But when I display the page, I see first, the tip of Manhattan and then my map. How can I avoid seeing New York first?
It doesn't happen every time. Click the "Next Post" area at the top right to see other maps. Watch the left map (satellite one) and after one or two, you will see the Manhattan map first for half a second, then my map.

  • Adam Czajczyk
    • Support Gorilla

    Hi Jim Vincent

    I hope you're well today and thank you for your question!

    I checked the site and all the maps and map options seems proper, there's no other maps (like coming from other plugin) that could potentially interfere, no relevant errors in browser console either.

    I expected at first that there might be some "delay" with KML loading and the map might be defaulting to e.g. server location (certainly not visitor location as I'm on the other side of the world and see that "tip of Manhattan" too) but server IP points to Amsterdam actually - so it's not that either. So, I still think it is some sort of "default" location but still, I agree that it should not show up at all.

    One thing that I noticed is that you're using both Hummingbird and WP Rocket (which provides quite an intense caching) which might actually cause some "asset load changes". Therefore, I'd like to ask you first to disable both WP Rocket caches and Hummingbird Page Cache (by the way, they shouldn't be run together as they'd overlap) and see if that stops the issue or not.

    If yes, we'll work on the settings to keep the site cached and still avoid the issue. If not, let me know please and I'll include our developers in the case as they'll need to take a closer look at the setup.

    Kind regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.