My Multisite keeps on changing pages status from "published" to "draft"

My Multisite keeps on changing pages status from "published" to "draft". I believe it has something to do with Pro Sites as I have other Multisites with same plugins and Divi theme but without Pro Sites and they're fine.
I've granted support in the back end.
I'm testing with a test account that has not been upgraded to Pro. It's setup to allow 1 page before needing to upgrade.
https://epromokits.com/davidtest/

It does allow to update to "published" but then moments later I go back and I see it's now a "draft".

Any help would be greatly appreciated. Thank you.

    Rupok

    Hi twinsmagic,

    So sorry to hear the inconvenience you are having. And thanks for granting Support Access.

    I could see the issue in action on your "davidtest" subsite. But to confirm if this is Pro Site specific issue or not, I created another test subsite without Pro Site status. Surprisingly, I could not regenerate this issue there. I could easily create and publish a page on that subsite without any problem. And I've waited for couple of minutes after creating that page. Still that page status hasn't changed to "Draft". You can check that page on this subsite: http://epromokits.com/testone/

    So I think, this issue is specific to your "davidtest" subsite. Now, to find out what is causing this, we need to do some tests. As we don't know if we are allowed to do those tests, I didn't go further.

    On that davidtest subsite, can you please delete all the pages (including the "e-promo-kit" page) even from the trash? And then try to create a fresh new page? Please let us know what happens.

    And as a new subsite doesn't have this issue, you can actually create another subsite and proceed there.

    Please let us know what you think about these. Also let us know if I'm missing anything.

    I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok