my registration process is not working

i couldn't figure out why people were registering for my site then not completing the payment section to gain access but now that i've tried testing it over and over again, it's not working. anyone can register but when they go to "SIGNUP" for a membership they get the message "Sorry, your signup request has failed. Try again. " but when you try again you get the same message.

can someone help me trouble shoot this ASAP???

  • Nastia
    • Support Rock Star

    Hello veazey

    I'm sorry to hear you have this issue!

    Would you please run a quick check for a conflict with another plugin?

    - Deactivate all other plugins
    - Switch to a default WordPress theme
    - Try to signup again. Do you still have the same error?

    If you are able to sign up, please activate one plugin at the time while testing to find a plugin or a theme that may cause this issue.

    Let us know how it went!

    Cheers,
    Nastia

  • veazey
    • Design Lord, Child of Thor

    it didn't fix the problem... same error.

    oo and if it helps, i deleted the new account you registered so you can test again....

    you know what plugin i didn't turn off was the wpmu dashboard, should i do it again and turn that one off too?

  • veazey
    • Design Lord, Child of Thor

    why isn't anyone helping me with this? i responded to your message right away last night and i haven't heard from yall at all today.

    i'm open to other ideas, if someone could please get back to me it would be greatly appreciated.

  • Sajid
    • DEV MAN’s Sidekick

    Hi veazey,
    Hope you are doing good today :slight_smile:

    I am sorry for delay on this ticket. I tried to reproduce this issue on my own website but could not replicate it. It worked fine for me with or without trial period and I am being redirected to thank you page after successfully subscribing the membership.

    I created a test paid membership without free trial on your website that worked fine as well. I could successfully signup for that membership.

    It appears that the issue is with Trial Membership add-on. But I am unable to replicate it on my own website using same plugin version with same setup. So there must be something wrong on your website that we need to troubleshoot further to find out the real culprit. For this purpose, I would need your websites FTP and WordPress admin login details to dig deeper. Please bear in mind that during troubleshooting, I will be deactivating plugins, themes and Membership 2 add-ons that may effect your live sites visitors/users. If its okay for you then please send in the requested credentials via our private contact form in following format.

    Subject: "Attn: Sajid Javed"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic (see screenshot) - this and the subject line ensure that it gets assigned to me :slight_smile:

    Also, for future reference, please don't bump the thread with multiple replies since this will push your thread towards the bottom of queue because our system feeds us tickets from oldest to newest. So each time you post a new reply, its treated as newest post and pushed down in the queue. Instead post one consolidated reply and wait for support staff to respond. We try our best to get back to our members as soon as possible. That is definitely not an excuse but explanation of how our system works.

    Take care and have a nice day :slight_smile:

    Kind Regards,
    Sajid

  • veazey
    • Design Lord, Child of Thor

    alright, because this problem hasn't been fixed, i decided to remove the free trial for now. after removing the free trial and going through the registration process and paying via paypal i'm so sad to report, i don't have immediate access to the site. it's been almost 30 minutes and the new account i created and paid for still doesn't have access...

  • Nastia
    • Support Rock Star

    Hello veazey

    I hope you are doing well today!

    I've checked and we haven't received your credentials. Please send to us your credentials so we can have a closer look at your site.

    On our contact page https://premium.wpmudev.org/contact/ select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me.

    Send in:

    Subject: "Attn: Nastia”
    - WordPress admin username
    - WordPress admin password
    - login url
    - FTP credentials (host/username/password)
    - link back to this thread for reference
    - any other relevant urls

    Would you please let us know under what user name you have registered?

    May I switch to PayPal sandbox and test it on your site? If this is an issue, please create a development copy of your site so we can test it there. You can use the Snapshot plugin to backup and restore your site.

    Please advise,

    Cheers,
    Nastia

  • veazey
    • Design Lord, Child of Thor

    i did send this info the same day sajid asked for it. i just sent it again "attn: nastia"

    i believe the user that i used and paid for is testingx1_June2 but it could have been testingx2_June2

    you can use sandbox, please do whatever you need to do, it's not working now so it doesn't matter what you do...

  • Sajid
    • DEV MAN’s Sidekick

    Hi veazey,
    Hope you are doing good today :slight_smile:

    Its strange neither I or my colleague Nastia got the credentials.

    Could you please send us credentials directly on contact@wpmudev.org email address with same format posted above ?

    Update: Meanwhile, I am trying to fix this issue using the support staff access.

    Look forward towards your response :slight_smile:

    Best Regards,
    Sajid

  • Sajid
    • DEV MAN’s Sidekick

    Hi veazey,
    Hope you are doing good today :slight_smile:

    I could replicate this issue on your site as well as on my own website using the PayPal Single Gateway. It does not activate the membership after payment is complete from PayPal checkout.

    I am marking it as confirmed bug and notifying the developer so it can be patched up as soon as possible. I will request developer to get patch for this version if possible.

    Please keep an eye on this thread for updates or you will also get notified right in your dashboard when there will be a new update.

    I am sorry for inconvenience and appreciate your patience shown here!

    Best Regards,
    Sajid

  • veazey
    • Design Lord, Child of Thor

    thank you for the response, and sorry for the delay in sending the FTP info. i generated a random password for you but didn't write it down so each time i had to resend teh FTP login info, i had to make a new password and this time i locked myself out.

    anyway, it's working now and i just sent you the email. it may have come from my personal email address caitlin_veazey@yahoo.com i'm not sure. please let me know if you need anything else and i really hope this gets resolved soon.

    i know it just adds to the problem but ultimately i would like to use the free trial as well if that can get fixed and functioning properly too i would greatly appreciate it.

    cheers, veazey

  • Sajid
    • DEV MAN’s Sidekick

    Hi veazey ,
    Hope you are doing good today :slight_smile:

    Thanks for sending in the credentials but as mentioned above, I could replicate this issue on your site as well as on my own test site.

    I already marked it as confirmed bug and notified the developer. We will soon fix this issue and release a new version containing this bug fixed.

    Thanks for sending the details, I will forward those to the developer in case they need that (chances are they would not need that though).

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid

  • Sajid
    • DEV MAN’s Sidekick

    Hi veazey,
    Hope you are doing good today :slight_smile:

    Please accept my sincere apologies for inconvenience. I have contacted the developer he said he is working on the payment issue and will be fixed and released in next version of this plugin. I am sorry but I can't give an ETA at the moment.

    I can see on other thread Ash already posted a response and assured you that the developer almost fixed that issue. It needs some testing and if everything went smooth we will definitely push an update.

    Thanks for your patience and have a nice day :slight_smile:

    Best Regards,
    Sajid

    • veazey
      • Design Lord, Child of Thor

      i was so happy to see a membership 2 pro plugin update so i quickly updated and activated. i found that it did fix ONE issue, so now i can manually add members, hallelujah!

      also, the MAIN issue that this post is for, "My Registration Process Is Not Working", is still not working, did yall know that this update would not fix that glitch???

      i'm trying so so so so so hard to be patient why silently cussing like a sailor on the inside. i'm terribly frustrated and i know you know becuz i've told you a hundred times.

  • Nastia
    • Support Rock Star

    Hello veazey

    I hope you are doing well today!

    I understand your frustration, however, this issue is required more time to fix, because it's more complex than the other. Our developers are working hard to find the solution. Once there is a hot fix out, before the plugin's update, Sajid or I will post it right here, in this thread.

    In the meantime, I have sent a message and asked our developers to provide a solution here as soon as possible.

    We appreciate your patience on this.

    Kind Regards,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.